前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >图论--2-SAT--POJ 3905 Perfect Election

图论--2-SAT--POJ 3905 Perfect Election

作者头像
风骨散人Chiam
发布2020-10-28 11:49:20
3790
发布2020-10-28 11:49:20
举报
文章被收录于专栏:CSDN旧文CSDN旧文

Perfect Election Time Limit: 5000MS         Memory Limit: 65536K Total Submissions: 964         Accepted: 431 Description

In a country (my memory fails to say which), the candidates {1, 2 ..., N} are running in the parliamentary election. An opinion poll asks the question "For any two candidates of your own choice, which election result would make you happy?". The accepted answers are shown in the table below, where the candidates i and j are not necessarily different, i.e. it may happen that i=j. There are M poll answers, some of which may be similar or identical. The problem is to decide whether there can be an election outcome (It may happen that all candidates fail to be elected, or all are elected, or only a part of them are elected. All these are acceptable election outcomes.) that conforms to all M answers. We say that such an election outcome is perfect. The result of the problem is 1 if a perfect election outcome does exist and 0 otherwise. Input

Each data set corresponds to an instance of the problem and starts with two integral numbers: 1≤N≤1000 and 1≤M≤1000000. The data set continues with M pairs ±i ±j of signed numbers, 1≤i,j≤N. Each pair encodes a poll answer as follows: 

Accepted answers to the poll question    Encoding I would be happy if at least one from i and j is elected.    +i +j I would be happy if at least one from i and j is not elected.    -i -j I would be happy if i is elected or j is not elected or both events happen.    +i -j I would be happy if i is not elected or j is elected or both events happen.    -i +j

The input data are separated by white spaces, terminate with an end of file, and are correct. Output

For each data set the program prints the result of the encoded election problem. The result, 1 or 0, is printed on the standard output from the beginning of a line. There must be no empty lines on output. Sample Input

3 3  +1 +2  -1 +2  -1 -3  2 3  -1 +2  -1 -2  +1 -2  2 4  -1 +2  -1 -2  +1 -2  +1 +2  2 8  +1 +2  +2 +1  +1 -2  +1 -2  -2 +1  -1 +1  -2 -2  +1 -1 Sample Output

1 1 0 1 Hint

For the first data set the result of the problem is 1; there are several perfect election outcomes, e.g. 1 is not elected, 2 is elected, 3 is not elected. The result for the second data set is justified by the perfect election outcome: 1 is not elected, 2 is not elected. The result for the third data set is 0. According to the answers -1 +2 and -1 -2 the candidate 1 must not be elected, whereas the answers +1 -2 and +1 +2 say that candidate 1 must be elected. There is no perfect election outcome. For the fourth data set notice that there are similar or identical poll answers and that some answers mention a single candidate. The result is 1.

题意:有N个候选人,给出M个限制条件。这些条件可以分成4类

1,+i +j 表示 i 和 j 至少选一个;

2,-i  -j 表示 i 和 j 最多选一个;

3,+i -j 表示 选i 和 不选j 最少成立一个 ;

4,-i +j 表示 不选i 和 选j 最少成立一个;      

问你有没有一种方案满足M个条件。

建图: 我用Ai表示i 被选上,!Ai表示i没有被选上。

对于1则有  非Ai -> Aj 和 非Aj -> Ai

对于2则有  Ai -> 非Aj 和 Aj -> 非Ai

对于3则有  Aj -> Ai 和 非Ai -> 非Aj

对于4则有  非Aj -> 非Ai 和 Ai -> Aj

记住三个符号六种基本建图方式,剩下的都可以修改:比如上面的4代表Ai and 非Aj=1,我们就是非Aj建图加上个Ai and Aj建图,自己画个图想想是不是? 地址

 AC代码:

代码语言:javascript
复制
#include <cstdio>
#include <cstring>
#include <queue>
#include <stack>
#include <vector>
#include <algorithm>
#define MAXN 2000+10
#define INF 1000000
#define eps 1e-5
using namespace std;
vector<int> G[MAXN];
int low[MAXN], dfn[MAXN];
int dfs_clock;
int sccno[MAXN], scc_cnt;
stack<int> S;
bool Instack[MAXN];
int N, M;
void init()
{
    for(int i = 1; i <= 2*N; i++) G[i].clear();
}
void getMap()
{
    int i, j;
    char op1, op2;
    while(M--)
    { 
        scanf("  %c%d %c%d", &op1, &i, &op2, &j);
        if(op1 == '+' && op2 == '+')
        {
            G[i + N].push_back(j);
            G[j + N].push_back(i);
        } 
        else if(op1 == '-' && op2 == '-')
        {
            G[i].push_back(j + N);
            G[j].push_back(i + N);
        }
        else if(op1 == '+' && op2 == '-')
        {
            G[i + N].push_back(j + N);//i若没有被选上 j一定没有被选上 
            G[j].push_back(i);//j被选上 i一定被选上 
        }
        else
        {
            G[i].push_back(j);//i被选上 j一定被选上 
            G[j + N].push_back(i + N);//j没有被选上 i一定没有被选上
        }
    }
}
void tarjan(int u, int fa)
{
    int v;
    low[u] = dfn[u] = ++dfs_clock;
    S.push(u);
    Instack[u] = true;
    for(int i = 0; i < G[u].size(); i++)
    {
        v = G[u][i];
        if(!dfn[v])
        {
            tarjan(v, u);
            low[u] = min(low[u], low[v]);
        }
        else if(Instack[v])
        low[u] = min(low[u], dfn[v]);
    }
    if(low[u] == dfn[u])
    {
        scc_cnt++;
        for(;;)
        {
            v = S.top(); S.pop();
            sccno[v] = scc_cnt;
            Instack[v] = false;
            if(v == u) break;
        }
    }
}
void find_cut(int l, int r)
{
    memset(low, 0, sizeof(low));
    memset(dfn, 0, sizeof(dfn));
    memset(sccno, 0, sizeof(sccno));
    memset(Instack, false, sizeof(Instack));
    dfs_clock = scc_cnt = 0;
    for(int i = l; i <= r; i++)
    if(!dfn[i]) tarjan(i, -1);
}
void solve()
{
    for(int i = 1; i <= N; i++)
    {
        if(sccno[i] == sccno[i+N])
        {
            printf("0\n");
            return ;
        }
    }
    printf("1\n");
}
int main()
{
    while(scanf("%d%d", &N, &M) != EOF)
    {
        init();
        getMap();
        find_cut(1, 2*N);
        solve();
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/11/17 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档