前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDU2937 YAPTCHA(威尔逊定理)

HDU2937 YAPTCHA(威尔逊定理)

作者头像
风骨散人Chiam
发布2020-10-28 16:01:35
3350
发布2020-10-28 16:01:35
举报
文章被收录于专栏:CSDN旧文

YAPTCHA Time Limit: 10000/5000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 2041 Accepted Submission(s): 1047

Problem Description The math department has been having problems lately. Due to immense amount of unsolicited automated programs which were crawling across their pages, they decided to put Yet-Another-Public-Turing-Test-to-Tell-Computers-and-Humans-Apart on their webpages. In short, to get access to their scientific papers, one have to prove yourself eligible and worthy, i.e. solve a mathematic riddle.

However, the test turned out difficult for some math PhD students and even for some professors. Therefore, the math department wants to write a helper program which solves this task (it is not irrational, as they are going to make money on selling the program).

The task that is presented to anyone visiting the start page of the math department is as follows: given a natural n, compute

where [x] denotes the largest integer not greater than x.

Input The first line contains the number of queries t (t <= 10^6). Each query consist of one natural number n (1 <= n <= 10^6).

Output For each n given in the input output the value of Sn.

Sample Input 13 1 2 3 4 5 6 7 8 9 10 100 1000 10000

Sample Output 0 1 1 2 2 2 2 3 3 4 28 207 1609 设P=3K+7即可,每当p是素数,值就加一完事了

代码语言:javascript
复制
#include <algorithm>
#include <cstdio>
#include <vector>
#include <iostream>
using namespace std;
typedef long long ll;
//const ll mod=1e9+7;
bool pri[3000036];int s[1000036];
int main()
{
    for(int i=0;i<3000010;i++)
        pri[i]=true;
    for(int i=2;i*i<3000010;i++)
        if(pri[i])
            for(int j=i*i;j<3000010;j+=i)
                pri[j]=false;
    s[1]=0;
    for(int i=12,j=2;i<=3000010;i+=3,j++)
    {
        if(pri[i+1])
            s[j]=s[j-1]+1;
        else
            s[j]=s[j-1];
    }
    int t;
    scanf("%d",&t);
    while(t--)
    {
        int n;
        scanf("%d",&n);
        printf("%d\n",s[n]);
    }
}```
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/11/30 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档