前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >思维+模拟--POJ 1013 Counterfeit Dollar

思维+模拟--POJ 1013 Counterfeit Dollar

作者头像
风骨散人Chiam
发布2020-11-06 00:45:27
3340
发布2020-11-06 00:45:27
举报
文章被收录于专栏:CSDN旧文

Sally Jones has a dozen Voyageur silver dollars. However, only eleven of the coins are true silver dollars; one coin is counterfeit even though its color and size make it indistinguishable from the real silver dollars. The counterfeit coin has a different weight from the other coins but Sally does not know if it is heavier or lighter than the real coins.

Happily, Sally has a friend who loans her a very accurate balance scale. The friend will permit Sally three weighings to find the counterfeit coin. For instance, if Sally weighs two coins against each other and the scales balance then she knows these two coins are true. Now if Sally weighs one of the true coins against a third coin and the scales do not balance then Sally knows the third coin is counterfeit and she can tell whether it is light or heavy depending on whether the balance on which it is placed goes up or down, respectively.

By choosing her weighings carefully, Sally is able to ensure that she will find the counterfeit coin with exactly three weighings.

Input The first line of input is an integer n (n > 0) specifying the number of cases to follow. Each case consists of three lines of input, one for each weighing. Sally has identified each of the coins with the letters A-L. Information on a weighing will be given by two strings of letters and then one of the words up'',down’’, or ``even’’. The first string of letters will represent the coins on the left balance; the second string, the coins on the right balance. (Sally will always place the same number of coins on the right balance as on the left balance.) The word in the third position will tell whether the right side of the balance goes up, down, or remains even. Output For each case, the output will identify the counterfeit coin by its letter and tell whether it is heavy or light. The solution will always be uniquely determined. Sample Input 1 ABCD EFGH even ABCI EFJK up ABIJ EFGH even Sample Output K is the counterfeit coin and it is light.

水题,思维,模拟的方式比较精巧。

代码语言:javascript
复制
#include <iostream>
#include <cmath>
#include <iomanip>
#include <cstring>
#include <algorithm>
using namespace std;
int main()
{
    int n, cnt, max;
    string s1, s2, temp;
    int flag[12];
    cin>>n;
    while (n--)
    {
        memset(flag, 0, sizeof(flag));
        for (int t = 1; t <= 3; ++t)
        {
            cin >> s1 >> s2 >> temp;
            if (temp=="even")
            {
                for (int i=0; i <s1.size(); ++i)
                {
                    flag[s1[i] - 'A'] = 10;
                    flag[s2[i] - 'A'] = 10;
                }
            }
            else if (temp== "up")
            {
                for (int i=0; i <s1.size(); ++i)
                {
                    if (flag[s1[i] - 'A'] != 10)
                        ++flag[s1[i] - 'A'];
                    if (flag[s2[i] - 'A'] != 10)
                        --flag[s2[i] - 'A'];
                }
            }
            else
            {
                for (int i=0; i <s1.size(); ++i)
                {
                    if (flag[s1[i] - 'A'] != 10)
                        --flag[s1[i] - 'A'];
                    if (flag[s2[i] - 'A'] != 10)
                        ++flag[s2[i] - 'A'];
                }
            }
        }
        max =cnt = 0;
        for (int i=0; i < 12; ++i)
        {
            if (flag[i] == 10)
                continue;
            if (max <= abs(flag[i]))
            {
                max = abs(flag[i]);
                cnt = i;
            }
        }
        if (flag[cnt] > 0)
            printf("%c is the counterfeit coin and it is heavy.\n", 'A' + cnt);
        else
            printf("%c is the counterfeit coin and it is light.\n", 'A' + cnt);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019/12/16 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档