前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 1306 Combinations

POJ 1306 Combinations

作者头像
谙忆
发布2021-01-19 15:16:51
4660
发布2021-01-19 15:16:51
举报
文章被收录于专栏:程序编程之旅

Description

Computing the exact number of ways that N things can be taken M at a time can be a great challenge when N and/or M become very large. Challenges are the stuff of contests. Therefore, you are to make just such a computation given the following: GIVEN: 5 <= N <= 100; 5 <= M <= 100; M <= N Compute the EXACT value of: C = N! / (N-M)!M! You may assume that the final value of C will fit in a 32-bit Pascal LongInt or a C long. For the record, the exact value of 100! is: 93,326,215,443,944,152,681,699,238,856,266,700,490,715,968,264,381,621, 468,592,963,895,217,599,993,229,915,608,941,463,976,156,518,286,253, 697,920,827,223,758,251,185,210,916,864,000,000,000,000,000,000,000,000 Input

The input to this program will be one or more lines each containing zero or more leading spaces, a value for N, one or more spaces, and a value for M. The last line of the input file will contain a dummy N, M pair with both values equal to zero. Your program should terminate when this line is read. Output

The output from this program should be in the form: N things taken M at a time is C exactly. Sample Input

100 6 20 5 18 6 0 0 Sample Output

100 things taken 6 at a time is 1192052400 exactly. 20 things taken 5 at a time is 15504 exactly. 18 things taken 6 at a time is 18564 exactly.

代码语言:javascript
复制
#include <iostream>
#include <stdio.h>
#include <string.h>
#include <stdlib.h>
using namespace std;

int main()
{
    int n,m;
    while(~scanf("%d%d",&n,&m)&&(n||m)){
        int s[200];
        bool vis[200];
        memset(vis,0,sizeof(vis));
        int x,y;
        if(n-m<m){
            x=n-m;/**x为小的那个数**/
            y=m;
        }
        else{
            x=m;
            y=n-m;
        }
        int sum=1;
        for(int i=y+1;i<=n;i++){
            sum*=i;
            for(int j=1;j<=x;j++){
                if(sum%j==0&&vis[j]==0){
                    vis[j]=1;
                    sum=sum/j;
                }
            }
        }
        printf("%d things taken %d at a time is %d exactly.\n",n,m,sum);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2015/10/26 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档