前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >POJ 1423 Big Number

POJ 1423 Big Number

作者头像
谙忆
发布2021-01-20 15:58:09
2470
发布2021-01-20 15:58:09
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Description

In many applications very large integers numbers are required. Some of these applications are using keys for secure transmission of data, encryption, etc. In this problem you are given a number, you have to determine the number of digits in the factorial of the number. Input

Input consists of several lines of integer numbers. The first line contains an integer n, which is the number of cases to be tested, followed by n lines, one integer 1 <= m <= 10^7 on each line. Output

The output contains the number of digits in the factorial of the integers appearing in the input. Sample Input

2 10 20 Sample Output

7 19

(部分转载) 补充知识 :若n=a+b^10,(a<1,b∈N),则n的位数为b。 所以要求一个数字num有多少位,可以用(int)log10(num)+1,这样就求出num有多少位. 如果sum=n*(n-1)(n-2)……*1,那么log10(sum)=log10(n)+ log10(n-1)+…..+log10(2)+log10(1)。即sum的位数是 ( int )( log10(n)+log10(n-1)+…..+log10(2)+log10(1) )+1。 (从小到大算)

下面这一种方法是程序外打表法,需要消耗时间。 还有一种是程序外打表,就是直接给复制,再导入,则肯定是0ms。

代码语言:javascript
复制
#include <stdio.h>
#include <math.h>

int a[10000010];
int main()
{
    double d;
    int i;
    int t;
    int n;
    for(i=1,d=0;i<10000005;i++){
        d+=log10(i);
        a[i]=(int)d+1;
    }

    scanf("%d",&t);
    while(t-->0){
        scanf("%d",&n);
        printf("%d\n",a[n]);

    }
    return 0;
}

还有一种方法: 利用Stirling公式. n!≈sqrt(2*pi*n)*[(n/e)^n] n越大,答案越准确。 在n=1的情况下,也最大不过相差0.2. 这里只要计算位数,所以是可以用的。 此处的: e ≈ 2.7182818284590452354, pi ≈ 3.141592653589793239;

代码语言:javascript
复制
#include<iostream>
#include<cmath>
using namespace std;
const double e = 2.7182818284590452354, pi = 3.141592653589793239;
double strling_digits_num(int n)
{
        return log10(2*pi*n)/2.0+n*(log10(n/e));
}

int main()
{
        int t;
        cin>>t;
        while(t--)
        {
                int n;
                cin>>n;
                double m=0;
                m=strling_digits_num(n);
                int answer=(int)m;
                answer++;
                cout<<answer<<endl;
        }
        return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2015-11-10 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档