前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ/HDU 1015 Safecracker(深搜)

HDOJ/HDU 1015 Safecracker(深搜)

作者头像
谙忆
发布2021-01-21 14:15:57
3430
发布2021-01-21 14:15:57
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description === Op tech briefing, 2002/11/02 06:42 CST === “The item is locked in a Klein safe behind a painting in the second-floor library. Klein safes are extremely rare; most of them, along with Klein and his factory, were destroyed in World War II. Fortunately old Brumbaugh from research knew Klein’s secrets and wrote them down before he died. A Klein safe has two distinguishing features: a combination lock that uses letters instead of numbers, and an engraved quotation on the door. A Klein quotation always contains between five and twelve distinct uppercase letters, usually at the beginning of sentences, and mentions one or more numbers. Five of the uppercase letters form the combination that opens the safe. By combining the digits from all the numbers in the appropriate way you get a numeric target. (The details of constructing the target number are classified.) To find the combination you must select five letters v, w, x, y, and z that satisfy the following equation, where each letter is replaced by its ordinal position in the alphabet (A=1, B=2, …, Z=26). The combination is then vwxyz. If there is more than one solution then the combination is the one that is lexicographically greatest, i.e., the one that would appear last in a dictionary.”

v - w^2 + x^3 - y^4 + z^5 = target

“For example, given target 1 and letter set ABCDEFGHIJKL, one possible solution is FIECB, since 6 - 9^2 + 5^3 - 3^4 + 2^5 = 1. There are actually several solutions in this case, and the combination turns out to be LKEBA. Klein thought it was safe to encode the combination within the engraving, because it could take months of effort to try all the possibilities even if you knew the secret. But of course computers didn’t exist then.”

=== Op tech directive, computer division, 2002/11/02 12:30 CST ===

“Develop a program to find Klein combinations in preparation for field deployment. Use standard test methodology as per departmental regulations. Input consists of one or more lines containing a positive integer target less than twelve million, a space, then at least five and at most twelve distinct uppercase letters. The last line will contain a target of zero and the letters END; this signals the end of the input. For each line output the Klein combination, break ties with lexicographic order, or ‘no solution’ if there is no correct combination. Use the exact format shown below.”

Sample Input 1 ABCDEFGHIJKL 11700519 ZAYEXIWOVU 3072997 SOUGHT 1234567 THEQUICKFROG 0 END

Sample Output LKEBA YOXUZ GHOST no solution

上个我用枚举做了,感觉不怎么好,毕竟是练算法的,就试试了深搜。 题意: 给你一个数,再给一个全部是大写字母构成的字符串。 从里面选5个字母v,m,x,y,z(不重复),计算v-m^2+x^3-y^4+z^4是否等于目标值 选出来的方案可能有很多种,那么你应该选择字典序最大的那种。

代码语言:javascript
复制
import java.util.Arrays;
import java.util.Scanner;

public class Main {
    static char handle[] = new char[6];
    static char at[]={' ','A','B','C','D','E','F','G','H','I','J'
            ,'K','L','M','N','O','P','Q','R','S','T','U','V','W','X','Y','Z'};
    static char chs[];
    static int target;
    static String str;
    static boolean map[];//标识是否已经用了
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        //for(int i='A';i<='Z';i++){
            //char c = (char)i;
            //System.out.print("'"+c+"',");
        //}
        while(sc.hasNext()){
            target = sc.nextInt();
            str = sc.next();
            if(target==0&&str.equals("END")){
                return;
            }
            map = new boolean[str.length()];
            chs = str.toCharArray();
            Arrays.sort(chs);
            for(int i=0,j=chs.length-1;i<chs.length/2;i++,j--){
                char c=chs[i];
                chs[i]=chs[j];
                chs[j]=c;
            }

            if(dfs(0)){
                for(int i=0;i<5;i++){
                    System.out.print(handle[i]);
                }
                System.out.println();
            }else{
                System.out.println("no solution");
            }


        }
    }
    private static boolean dfs(int m) {
        if(m==5){
            if( res(handle[0],handle[1],handle[2],handle[3],handle[4]) ){
                return true;
            }
            return false;
        }else{
            for(int i=0;i<str.length();i++){
                if(!map[i]){
                    map[i]=true;
                    handle[m]=chs[i];
                    if(dfs(m+1)){
                        return true;
                    }
                    map[i]=false;
                }
            }
        }

        return false;
    }
    private static boolean res(char a, char b, char c, char d, char e) {
        int ap[] = new int[5];
        for(int j=0;j<ap.length;j++){
            for(int i=1;i<at.length;i++){
                if(j==0){
                    if(a==at[i]){
                        ap[0]=i;
                        break;
                    }
                }else
                if(j==1){
                    if(b==at[i]){
                        ap[1]=i;
                        break;
                    }
                }else
                if(j==2){
                    if(c==at[i]){
                        ap[2]=i;
                        break;
                    }
                }else
                if(j==3){
                    if(d==at[i]){
                        ap[3]=i;
                        break;
                    }
                }else
                if(j==4){
                    if(e==at[i]){
                        ap[4]=i;
                        break;
                    }
                }
            }
        }

        int sum=0;
        for(int i=0;i<ap.length;i++){
            if(i%2==0){
                sum+=Math.pow(ap[i], i+1);
            }else{
                sum-=Math.pow(ap[i], i+1);
            }
        }
        if(sum==target){
            return true;
        }else{
            return false;
        }
    }
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2016-06-14 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档