前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ 1076 An Easy Task(闰年计算)

HDOJ 1076 An Easy Task(闰年计算)

作者头像
谙忆
发布2021-01-21 14:25:12
2930
发布2021-01-21 14:25:12
举报
文章被收录于专栏:程序编程之旅

Problem Description Ignatius was born in a leap year, so he want to know when he could hold his birthday party. Can you tell him?

Given a positive integers Y which indicate the start year, and a positive integer N, your task is to tell the Nth leap year from year Y.

Note: if year Y is a leap year, then the 1st leap year is year Y.

Input The input contains several test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. Each test case contains two positive integers Y and N(1<=N<=10000).

Output For each test case, you should output the Nth leap year from year Y.

Sample Input 3 2005 25 1855 12 2004 10000

Sample Output 2108 1904 43236

Hint: We call year Y a leap year only if (Y%4==0 && Y%100!=0) or Y%400==0.

题意就是:输入一个年份year和一个n,求这个year之后的第n个闰年, 如果year是闰年,则算第一个闰年。

直接暴力做,并没有超时。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            int year = sc.nextInt();
            int n = sc.nextInt();
            int nyear = 0;
            if((year%4==0&&year%100!=0)|(year%400==0)){
                nyear=1;
            }//如果year是闰年,nyear就加一
            while(nyear<n){//当nyear小于n时,就循环
                year++;
                if((year%4==0&&year%100!=0)|(year%400==0)){
                    nyear++;
                }//year是闰年,nyear就加加
            }
            System.out.println(year);
        }
    }

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/04/01 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档