前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
圈层
工具
发布
首页
学习
活动
专区
圈层
工具
社区首页 >专栏 >HDOJ 1266 Reverse Number(数字反向输出题)

HDOJ 1266 Reverse Number(数字反向输出题)

作者头像
谙忆
发布2021-01-21 14:28:28
发布2021-01-21 14:28:28
39000
代码可运行
举报
文章被收录于专栏:程序编程之旅程序编程之旅
运行总次数:0
代码可运行

Problem Description Welcome to 2006’4 computer college programming contest!

Specially, I give my best regards to all freshmen! You are the future of HDU ACM! And now, I must tell you that ACM problems are always not so easy, but, except this one… Ha-Ha!

Give you an integer; your task is to output its reverse number. Here, reverse number is defined as follows: 1. The reverse number of a positive integer ending without 0 is general reverse, for example, reverse (12) = 21; 2. The reverse number of a negative integer is negative, for example, reverse (-12) = -21; 3. The reverse number of an integer ending with 0 is described as example, reverse (1200) = 2100.

Input Input file contains multiple test cases. There is a positive integer n (n<100) in the first line, which means the number of test cases, and then n 32-bit integers follow.

Output For each test case, you should output its reverse number, one case per line.

Sample Input 3 12 -12 1200

Sample Output 21 -21 2100

注意:前导0的情况! 例: 输入: 3 -0012560020 00000 00205 输出为: -2006521 0 502

代码语言:javascript
代码运行次数:0
运行
复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while (t-- > 0) {
            String str = sc.next();
            int instr = Integer.parseInt(str);
            //System.out.println(instr);
            str = Integer.toString(instr);

            //System.out.println(str);
            if (str.charAt(0) == '-') {
                System.out.print("-");
                int k = 0;
                boolean isOne=false;

                //System.out.println(str.length()+"aaa");

                for (int i = str.length() - 1; i >= 1; i--) {
                    //System.out.println("a:  "+str.charAt(i));
                    if(str.charAt(i)!='0'&&!isOne){
                        //System.out.println("++ "+str.charAt(i));
                        isOne=true;
                    }

                    if (isOne) {
                        System.out.print(str.charAt(i));
                        k++;
                    }
                }
                for (int i = 1; i < str.length() - k; i++) {
                    System.out.print(0);
                }
                System.out.println();
            } else {
                int k = 0;
                boolean isOne=false;
                for (int i = str.length() - 1; i >= 0; i--) {
                    if(str.charAt(i)!='0'&&!isOne){
                        isOne=true;
                    }

                    if (isOne) {
                        System.out.print(str.charAt(i));
                        k++;

                    }
                }

                for (int i = 0; i < str.length() - k; i++) {
                    System.out.print(0);
                }
                System.out.println();

            }

        }
    }

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/04/06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档