前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 1570 A C

HDOJ(HDU) 1570 A C

作者头像
谙忆
发布2021-01-21 15:22:42
2300
发布2021-01-21 15:22:42
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description Are you excited when you see the title “AC” ? If the answer is YES , AC it ;

You must learn these two combination formulas in the school . If you have forgotten it , see the picture.

Now I will give you n and m , and your task is to calculate the answer .

Input In the first line , there is a integer T indicates the number of test cases. Then T cases follows in the T lines. Each case contains a character ‘A’ or ‘C’, two integers represent n and m. (1<=n,m<=10)

Output For each case , if the character is ‘A’ , calculate A(m,n),and if the character is ‘C’ , calculate C(m,n). And print the answer in a single line.

Sample Input 2 A 10 10 C 4 2

Sample Output 3628800 6

题意:很简单,看图片就能理解了。 水题一个!就不多解释了。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t = sc.nextInt();
        while(t-->0){
            String str = sc.next();
            int n = sc.nextInt();
            int m =sc.nextInt();

            if(str.charAt(0)=='A'){
                System.out.println(a(n,m));
            }else{
                System.out.println(c(n,m));
            }

        }

    }

    private static int c(int n, int m) {
        int num =1;
        if(n-m>m){
            m=n-m;
        }
        int cnum=1;
        for(int i=1;i<=n-m;i++){
            cnum=cnum*i;
        }
        for(int i=m+1;i<=n;i++){
            num=num*i;
        }
        return num/cnum;
    }

    private static int a(int n, int m) {
        int num=1;
        for(int i=n-m+1;i<=n;i++){
            num=num*i;
        }
        return num;
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-04-19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档