前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 1563 Find your present!(异或)

HDOJ(HDU) 1563 Find your present!(异或)

作者头像
谙忆
发布2021-01-21 15:23:43
1790
发布2021-01-21 15:23:43
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description In the new year party, everybody will get a “special present”.Now it’s your turn to get your special present, a lot of presents now putting on the desk, and only one of them will be yours.Each present has a card number on it, and your present’s card number will be the one that different from all the others.For example, there are 5 present, and their card numbers are 1, 2, 3, 2, 1.so your present will be the one with the card number of 3, because 3 is the number that different from all the others.

Input The input file will consist of several cases. Each case will be presented by an integer n (1<=n<=200, and n is odd) at first. Following that, n positive integers will be given in a line. These numbers indicate the card numbers of the presents.n = 0 ends the input.

Output For each case, output an integer in a line, which is the card number of your present.

Sample Input 5 1 1 3 2 2 3 1 2 1 0

Sample Output 3 2

题意:找出一行数中独立的数!

按位异或的3个特点: (1) 0^0=0,0^1=1 0异或任何数=任何数 (2) 1^0=1,1^1=0 1异或任何数-任何数取反 (3) 任何数异或自己=把自己置0

先说一下异或运算的运算法则: 1. a ^ b = b ^ a 2. a ^ b ^ c = a ^ (b ^ c) = (a ^ b) ^ c 3. d = a ^ b ^ c 可以推出 a = d ^ b ^ c 4. a ^ b ^ a = b

对于性质1,显而易见。 对于性质2和4,就是可以查找出一组数列中具有奇数个数的数。比如: 题目:有2n+1个数,其中有n个数出现过两次,只有一个数字出现过一次。要求是找出这个数字。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);

        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n==0){
                return ;
            }
            int m =0;
            int s;
            while(n-->0){
                s = sc.nextInt();
                m = m^s;
            }
            System.out.println(m);
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/04/19 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档