前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 1720 A+B Coming(进制)

HDOJ(HDU) 1720 A+B Coming(进制)

作者头像
谙忆
发布2021-01-21 15:26:33
2880
发布2021-01-21 15:26:33
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description Many classmates said to me that A+B is must needs. If you can’t AC this problem, you would invite me for night meal. ^_^

Input Input may contain multiple test cases. Each case contains A and B in one line. A, B are hexadecimal number. Input terminates by EOF.

Output Output A+B in decimal number in one line.

Sample Input 1 9 A B a b

Sample Output 10 21 21

超简单的题目,,,就是给2个16进制的数,将它们的和按10进制输出! JAVA可以直接读取16进制的数!

代码语言:javascript
复制
import java.util.Scanner;

public class Main {
    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int a = sc.nextInt(16);
            int b = sc.nextInt(16);
            System.out.println(a+b);
        }

    }

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/04/22 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档