前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2123 An easy problem(简单题...)

HDOJ(HDU) 2123 An easy problem(简单题...)

作者头像
谙忆
发布2021-01-21 15:40:18
3330
发布2021-01-21 15:40:18
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description In this problem you need to make a multiply table of N * N ,just like the sample out. The element in the ith row and jth column should be the product(乘积) of i and j.

Input The first line of input is an integer C which indicate the number of test cases.

Then C test cases follow.Each test case contains an integer N (1<=N<=9) in a line which mentioned above.

Output For each test case, print out the multiply table.

Sample Input 2 1 4

Sample Output 1 1 2 3 4 2 4 6 8 3 6 9 12 4 8 12 16

就是输入t个数,对于每个数n,输出n*n个数。 i为1-n,j为1-n,输出i*j。 每一行最后一个输出后面没有空格啊!!!

代码语言:javascript
复制
import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int n =sc.nextInt();
            for(int i=1;i<=n;i++){
                for(int j=1;j<=n;j++){
                    if(j==1){
                        System.out.print(i*j);
                    }else{
                        System.out.print(" "+i*j);
                    }
                }
                System.out.println();
            }
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/05/03 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档