前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2132 An easy problem

HDOJ(HDU) 2132 An easy problem

作者头像
谙忆
发布2021-01-21 15:40:29
2240
发布2021-01-21 15:40:29
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description We once did a lot of recursional problem . I think some of them is easy for you and some if hard for you. Now there is a very easy problem . I think you can AC it. We can define sum(n) as follow: if i can be divided exactly by 3 sum(i) = sum(i-1) + i*i*i;else sum(i) = sum(i-1) + i; Is it very easy ? Please begin to program to AC it..-_-

Input The input file contains multilple cases. Every cases contain only ont line, every line contains a integer n (n<=100000). when n is a negative indicate the end of file.

Output output the result sum(n).

Sample Input 1 2 3 -1

Sample Output 1 3 30

水题。。注意范围。!!!java用long型可以AC,只是注意中间计算结果也有可能溢出int型范围,也要转换为long才行。 还有,注意判断条件退出不是输入-1,而是输入小于0的数就是退出了。

代码语言:javascript
复制
import java.util.Scanner;

public class Main{
    static long db[] = new long[100001];
    public static void main(String[] args) {
        dabiao();
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n<0){
                return;
            }
            System.out.println(db[n]);
        }
    }
    private static void dabiao() {
        db[1]=1;
        db[2]=3;
        for(int i=3;i<db.length;i++){
            if(i%3==0){
                db[i]=db[i-1]+i*(long)i*i;
                //这里的i*i要强转成long,long*int还是long,否则i*i*i会超int范围
            }else{
                db[i]=db[i-1]+i;
            }
        }

    }

}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/05/03 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档