前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2135 Rolling table

HDOJ(HDU) 2135 Rolling table

作者头像
谙忆
发布2021-01-21 15:40:47
1930
发布2021-01-21 15:40:47
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description After the 32nd ACM/ICPC regional contest, Wiskey is beginning to prepare for CET-6. He has an English words table and read it every morning. One day, Wiskey’s chum wants to play a joke on him. He rolling the table, and tell Wiskey how many time he rotated. Rotate 90 degrees clockwise or count-clockwise each time. The table has n*n grids. Your task is tell Wiskey the final status of the table.

Input Each line will contain two number. The first is postive integer n (0 < n <= 10). The seconed is signed 32-bit integer m. if m is postive, it represent rotate clockwise m times, else it represent rotate count-clockwise -m times. Following n lines. Every line contain n characters.

Output Output the n*n grids of the final status.

Sample Input 3 2 123 456 789 3 -1 123 456 789

Sample Output 987 654 321 369 258 147

(注意是字符啊!字符!我开始以为是n*n个1-n*n的数字。。。WA了几次) 输入n*n个字符,每次旋转以90°为单位,m>0表示顺时针旋转 m<0逆时针旋转。 矩阵旋转后存在四种状态。所以将m取余4,然后判断是哪种状态,然后旋转即可。

代码语言:javascript
复制
import java.util.Scanner;

public class Main {

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        while(sc.hasNext()){
            int n = sc.nextInt();
            int m = sc.nextInt();
            String strs[]=new String[n];
            for(int i=0;i<n;i++){
                strs[i]=sc.next();
            }
            if(m%4==0){
                for(int i=0;i<n;i++){
                    System.out.println(strs[i]);
                }
                continue;
            }
            if(m>0){
                m=m%4;
                if(m==1){
                    for(int i=0;i<n;i++){
                        for(int j=n-1;j>=0;j--){
                            System.out.print(strs[j].charAt(i));
                        }
                        System.out.println();
                    }
                    continue;
                }
                if(m==2){
                    for(int i=n-1;i>=0;i--){
                        for(int j=n-1;j>=0;j--){
                            System.out.print(strs[i].charAt(j));
                        }
                        System.out.println();
                    }
                    continue;
                }
                if(m==3){
                    for(int i=n-1;i>=0;i--){
                        for(int j=0;j<n;j++){
                            System.out.print(strs[j].charAt(i));
                        }
                        System.out.println();
                    }
                    continue;
                }
            }
            if(m<0){
                m=m*(-1);
                m=m%4;
                if(m==3){
                    for(int i=0;i<n;i++){
                        for(int j=n-1;j>=0;j--){
                            System.out.print(strs[j].charAt(i));
                        }
                        System.out.println();
                    }
                    continue;
                }
                if(m==2){
                    for(int i=n-1;i>=0;i--){
                        for(int j=n-1;j>=0;j--){
                            System.out.print(strs[i].charAt(j));
                        }
                        System.out.println();
                    }
                    continue;
                }
                if(m==1){
                    for(int i=n-1;i>=0;i--){
                        for(int j=0;j<n;j++){
                            System.out.print(strs[j].charAt(i));
                        }
                        System.out.println();
                    }
                }
            }
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/05/03 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档