前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2161 Primes(素数打表)

HDOJ(HDU) 2161 Primes(素数打表)

作者头像
谙忆
发布2021-01-21 15:42:23
2140
发布2021-01-21 15:42:23
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description Write a program to read in a list of integers and determine whether or not each number is prime. A number, n, is prime if its only divisors are 1 and n. For this problem, the numbers 1 and 2 are not considered primes.

Input Each input line contains a single integer. The list of integers is terminated with a number<= 0. You may assume that the input contains at most 250 numbers and each number is less than or equal to 16000.

Output The output should consists of one line for every number, where each line first lists the problem number, followed by a colon and space, followed by “yes” or “no”.

Sample Input 1 2 3 4 5 17 0

Sample Output 1: no 2: no 3: yes 4: no 5: yes 6: yes

给你一个数,判断它是不是素数,是素数输出**: yes,不是就输出 **: no 注意:1和2要输出no。 还有,判断结束的标志是n<=0.

代码语言:javascript
复制
import java.util.Arrays;
import java.util.Scanner;

public class Main{
    static boolean db[] = new boolean[16001];
    public static void main(String[] args) {
        prime();
        Scanner sc = new Scanner(System.in);
        int t=0;
        while(sc.hasNext()){
            int n =sc.nextInt();
            if(n<=0){
                break;
            }
            if(db[n]){
                System.out.println((++t)+": yes");
            }else{
                System.out.println((++t)+": no");
            }
        }
    }
    private static void prime() {
        Arrays.fill(db, true);
        db[1]=false;
        db[2]=false;
        for(int i=2;i<=Math.sqrt(db.length);i++){
            for(int j=i+i;j<db.length;j+=i){
                if(db[j]){
                    db[j]=false;
                }
            }
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016/05/05 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档