前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ(HDU) 2317 Nasty Hacks(比较、)

HDOJ(HDU) 2317 Nasty Hacks(比较、)

作者头像
谙忆
发布2021-01-21 15:44:14
3970
发布2021-01-21 15:44:14
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description You are the CEO of Nasty Hacks Inc., a company that creates small pieces of malicious software which teenagers may use to fool their friends. The company has just finished their first product and it is time to sell it. You want to make as much money as possible and consider advertising in order to increase sales. You get an analyst to predict the expected revenue, both with and without advertising. You now want to make a decision as to whether you should advertise or not, given the expected revenues.

Input The input consists of n cases, and the first line consists of one positive integer giving n. The next n lines each contain 3 integers, r, e and c. The first, r, is the expected revenue if you do not advertise, the second, e, is the expected revenue if you do advertise, and the third, c, is the cost of advertising. You can assume that the input will follow these restrictions: -106 ≤ r, e ≤ 106 and 0 ≤ c ≤ 106.

Output Output one line for each test case: “advertise”, “do not advertise” or “does not matter”, presenting whether it is most profitable to advertise or not, or whether it does not make any difference.

Sample Input 3 0 100 70 100 130 30 -100 -70 40

Sample Output advertise does not matter do not advertise

嗯。。水题。。

题意就是输入的: 第一个数a是:做研发能赚多少钱,负数代表亏多少钱。 第二个数b是:做广告能赚多少钱。 第三个数c是:做广告的成本。 也就是比较a和(b+c)谁大谁小,还是相等。 如果a大:输出:do not advertise 如果a小:输出:advertise 如果一样大:输出:does not matter

代码语言:javascript
复制
import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int a =sc.nextInt();
            int b =sc.nextInt();
            int c =sc.nextInt();

            if(a==(b-c)){
                System.out.println("does not matter");
            }else if(a>(b-c)){
                System.out.println("do not advertise");
            }else{
                System.out.println("advertise");
            }
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-06 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档