前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >HDOJ/HDU 2560 Buildings(嗯~水题)

HDOJ/HDU 2560 Buildings(嗯~水题)

作者头像
谙忆
发布2021-01-21 15:51:45
2530
发布2021-01-21 15:51:45
举报
文章被收录于专栏:程序编程之旅程序编程之旅

Problem Description We divide the HZNU Campus into N*M grids. As you can see from the picture below, the green grids represent the buidings. Given the size of the HZNU Campus, and the color of each grid, you should count how many green grids in the N*M grids.

Input Standard input will contain multiple test cases. The first line of the input is a single integer T which is the number of test cases. T test cases follow. The first line of each test case contains two integers n and m(1<=n,m<=100), the size of the campus. Then follow n lines, each line containing m integers. The j-th integer in the i-th line is the color of that grid, 0 stands for white color, while 1 stands for green.

Output Results should be directed to standard output. For each case, output an integers T, the total green grids in the N*M size campus.

Sample Input 2 2 2 1 1 0 0 3 3 1 0 1 0 0 1 1 1 0

Sample Output 2 5

水题一个~~ 就是一个学校n*m的面积,然后有建筑~ 1代表建筑,统计建筑的总数~

代码语言:javascript
复制
import java.util.Scanner;

public class Main{

    public static void main(String[] args) {
        Scanner sc = new Scanner(System.in);
        int t =sc.nextInt();
        while(t-->0){
            int n =sc.nextInt();
            int m =sc.nextInt();
            int sum=0;
            for(int i=0;i<n;i++){
                for(int j=0;j<m;j++){
                    int a =sc.nextInt();
                    if(a==1){
                        sum++;
                    }
                }
            }
            System.out.println(sum);
        }
    }
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2016-05-17 ,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档