专栏首页AnRFDevPython3.5 PyQt5 安装

Python3.5 PyQt5 安装

在Windows和Ubuntu下安装PyQt5 需要先安装并配置好Python,Windows下需要配置环境变量。PyQt需要对应上Python版本。

Windows环境

用pip3安装PyQt5

先确认Python相关环境变量已经配置好,比如:

D:\python36;D:\python36\Scripts;D:\python36\libs;

然后运行pip3,参考 PyQt5 Download

pip3 install PyQt5

从网上下载相关文件并安装,等待过程比较长。

PyQt5-5.6-gpl exe 安装方式

Win7 Python3.5.1

PyQt5-5.6-gpl-Py3.5-Qt5.6.0-x64-2.exe (最新版本已经不再提供exe版本)

先安装Python3.5.1到 E:\Python351 再去官网下载PyQt5,翻墙后下载速度更快。双击安装,PyQt5会自动找到Python35的目录。 本例中PyQt5安装到 E:\Python351\Lib\site-packages\PyQt5

现在就可以使用PyQt5了。

>>> from PyQt5.QtWidgets import *

在命令行显示一个label试一下

>>> import sys
>>> from PyQt5 import QtWidgets
>>> app = QtWidgets.QApplication(sys.argv)
>>> label = QtWidgets.QLabel('Label')
>>> label.resize(150,100)
>>> label.show()

Ubuntu 16.04

Python3.5 直接安装

sudo apt-get install python3-dev
sudo apt-get install python3-pyqt5
sudo apt-get install qt5-default qttools5-dev-tools
designer # 启动designer

安装pyuic5

sudo apt-get install pyqt5-dev-tools

本文参与腾讯云自媒体分享计划,欢迎正在阅读的你也加入,一起分享。

我来说两句

0 条评论
登录 后参与评论

相关文章

  • 安装Python3.5

    (这样做的目的是在系统任意目录下敲入python调用的都是python3.5的命令,而非系统默认的2.6.6。但是这样会导致依赖python2.6的yum不能使...

    py3study
  • Linux安装python3.5

    Tencent JCoder
  • Centos7安装python3.5

    CentOS 7自带的Python版本为2.7,首先需要升级到3.5版本。由于旧版本的Python已被深度依赖,所以不能卸载原有的Python,只能全新安装。

    py3study
  • CentOS下安装python3.5+

    上面也是验证Scrapy框架安装成功,因为我们进行了import scrapy没有进行报错。

    py3study
  • CentOS 7安装Python3.5

    yum install openssl-devel bzip2-devel expat-devel gdbm-devel readline-devel sqli...

    知忆
  • PyInstaller的安装和使用的详细步骤

    写的一些爬虫,不想太麻烦的使用pyqt5来写界面,就简单使用pyinstaller来做一个.exe的文件

    砸漏
  • Mac系统安装Python3.5

         Note: Mac自带了python2.X的执行环境,如果输入python,则进入了python2的交互式环境,两个版本不兼容

    py3study
  • 在linux下,安装python3.5.

    因为系统中安装了python2.6.6,所以在安装时,需要指定一个目录来安装这个文件,我使用的是/usr/local/python3

    py3study
  • python3.5安装_linux系统环

    yum install openssl-devel bzip2-devel expat-devel gdbm-devel readline-devel sqli...

    py3study
  • Python3.7下安装pyqt5的方法步骤(图文)

    第二步:执行安装pyqt5的命令:python37 -m pip install pyqt5

    砸漏
  • python3.5 + PyQt5 +Eric6实现简易计算器

    python动手项目之一,很久之前写的了,现在拿出来,我刚学python练手的项目。

    雷子
  • PyQt5+Pycharm安装和配置图文教程详解

    之前安装过anaconda,里面是含有pyqt的,在环境里搜索可以看到,但是针对实际开发,并没有全部的qt5工具,所以需要再次安装。

    砸漏
  • 删除系统 Python 引发的惨案

    由于实验需要使用 Python3.6 以上版本,于是决定卸载 Python3.5。

    咸鱼学Python
  • PyQT5编译安装[Python3.6.1 + VS2013 + QT5.5]

    原文链接:https://blog.csdn.net/humanking7/article/details/80393070

    祥知道
  • 一个因为删除系统 Python 引发的惨案...

    由于实验需要使用 Python3.6 以上版本,于是决定卸载 Python3.5。

    编程文青李狗蛋
  • ubuntu12.04安装python3

    默认系统已经自带了python2.7。在安装python3.5的时候,不要将python2.7的版本删掉,因为系统本身有很多功能都是需要python2.7的支持...

    py3study
  • 解决安装新版PyQt5、PyQT5-tool后打不开并Designer.exe提示no Qt platform plugin的问题

    1、问题:安装完成后PyQt5、PyQT5-tool后,双击Designer.exe或者添加External Tools后打开Designer有问题,提示no ...

    砸漏
  • Pycharm安装配置PyQt5与Qt Designer

    由于网络原因,直接使用pip install pyqt5 pyqt5-tools会失败,建议使用阿里镜像安装。 pip install -i http://m...

    菲宇
  • pycharm下配置pyqt5的教程(anaconda虚拟环境下+tensorflow)

    1.打开anaconda prompt命令窗口,激活虚拟环境:activate tensorflow

    砸漏

扫码关注云+社区

领取腾讯云代金券