前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >2012 ACM/ICPC Asia Regional Tianjin Online-Faulty Odometer

2012 ACM/ICPC Asia Regional Tianjin Online-Faulty Odometer

作者头像
Java架构师必看
发布2021-05-14 10:31:08
2270
发布2021-05-14 10:31:08
举报
文章被收录于专栏:Java架构师必看

Faulty Odometer

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1027    Accepted Submission(s): 681

Problem Description

  You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).

Input

  Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.

Output

  Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.

Sample Input

代码语言:javascript
复制
   15
2005
250
1500
999999
0

Sample Output

代码语言:javascript
复制
   15: 12
2005: 1028
250: 160
1500: 768
999999: 262143
  
  
  
  
   
    
  
  
  
  
   
   题意:有个特殊汽车的行程表,每逢数字3和8会跳过直接到4和9,给你一个行程表的示数,求汽车实际走的路程。
  
  
  
  
   
   思路:普通的进制转换,将8进制数转为10进制即可,注意数字跳过的处理。
  
  
  
  
   
   #include<stdio.h> 
int ans[11]={0,1,2,0,3,4,5,6,0,7}; 
int main() 
{ 
    int n; 
    while(scanf("%d",&n)&&n) 
    { 
        int s=0,a,b=1; 
        int t=n,i; 
        while(t) 
        { 
            int h=1;         
            a=t%10; 
            t=t/10; 
            for(i=1;i<b;i++) 
                h*=8; 
            s+=(ans[a]*h); 
            b++; 
        } 
        printf("%d: %d\n",n,s); 
    } 
    return 0; 
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档