Faulty Odometer
Time Limit: 2000/1000 MS (Java/Others) Memory Limit: 32768/32768 K (Java/Others) Total Submission(s): 1027 Accepted Submission(s): 681
Problem Description
You are given a car odometer which displays the miles traveled as an integer. The odometer has a defect, however: it proceeds from the digit 2 to the digit 4 and from the digit 7 to the digit 9, always skipping over the digit 3 and 8. This defect shows up in all positions (the one's, the ten's, the hundred's, etc.). For example, if the odometer displays 15229 and the car travels one mile, odometer reading changes to 15240 (instead of 15230).
Input
Each line of input contains a positive integer in the range 1..999999999 which represents an odometer reading. (Leading zeros will not appear in the input.) The end of input is indicated by a line containing a single 0. You may assume that no odometer reading will contain the digit 3 and 8.
Output
Each line of input will produce exactly one line of output, which will contain: the odometer reading from the input, a colon, one blank space, and the actual number of miles traveled by the car.
Sample Input
15
2005
250
1500
999999
0
Sample Output
15: 12
2005: 1028
250: 160
1500: 768
999999: 262143
题意:有个特殊汽车的行程表,每逢数字3和8会跳过直接到4和9,给你一个行程表的示数,求汽车实际走的路程。
思路:普通的进制转换,将8进制数转为10进制即可,注意数字跳过的处理。
#include<stdio.h>
int ans[11]={0,1,2,0,3,4,5,6,0,7};
int main()
{
int n;
while(scanf("%d",&n)&&n)
{
int s=0,a,b=1;
int t=n,i;
while(t)
{
int h=1;
a=t%10;
t=t/10;
for(i=1;i<b;i++)
h*=8;
s+=(ans[a]*h);
b++;
}
printf("%d: %d\n",n,s);
}
return 0;
}