前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PKU 3624 Charm Bracelet

PKU 3624 Charm Bracelet

作者头像
Java架构师必看
发布2021-05-14 10:31:39
2090
发布2021-05-14 10:31:39
举报
文章被收录于专栏:Java架构师必看

Charm Bracelet

Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
Total Submission(s) : 26   Accepted Submission(s) : 16

Problem Description

Bessie has gone to the mall's jewelry store and spies a charm bracelet. Of course, she'd like to fill it with the best charms possible from theN (1 ≤ N ≤ 3,402) available charms. Each charm i in the supplied list has a weightWi (1 ≤ Wi ≤ 400), a 'desirability' factorDi (1 ≤ Di ≤ 100), and can be used at most once. Bessie can only support a charm bracelet whose weight is no more thanM (1 ≤ M ≤ 12,880).

Given that weight limit as a constraint and a list of the charms with their weights and desirability rating, deduce the maximum possible sum of ratings.

Input

* Line 1: Two space-separated integers: N and M * Lines 2..N+1: Line i+1 describes charm i with two space-separated integers:Wi and Di

Output

* Line 1: A single integer that is the greatest sum of charm desirabilities that can be achieved given the weight constraints

Sample Input

代码语言:javascript
复制
    4 6
1 4
2 6
3 12
2 7

Sample Output

代码语言:javascript
复制
    23

Source

PKU

01背包入门题

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
int f[13333];
int wi[4444];
int di[4444];
int max(int a,int b)
{
    return a>b?a:b;
}
int main()
{
    int m,n;
    int i,j;
    while(scanf("%d%d",&n,&m)!=EOF)
    {
        for(i=0;i<n;i++)
            scanf("%d%d",&wi[i],&di[i]);
        memset(f,0,sizeof(f));
        for(i=0;i<n;i++)
        {
            for(j=m;j>=wi[i];j--)
            {
                f[j]=max(f[j],f[j-wi[i]]+di[i]);
            }
        }
        printf("%d\n",f[m]);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Time Limit : 2000/1000ms (Java/Other)   Memory Limit : 131072/65536K (Java/Other)
  • Total Submission(s) : 26   Accepted Submission(s) : 16
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档