前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >hdu 1712 ACboy needs your help

hdu 1712 ACboy needs your help

作者头像
Java架构师必看
发布2021-05-14 10:32:35
1700
发布2021-05-14 10:32:35
举报
文章被收录于专栏:Java架构师必看

ACboy needs your help

Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
Total Submission(s) : 158   Accepted Submission(s) : 74

Problem Description

ACboy has N courses this term, and he plans to spend at most M days on study.Of course,the profit he will gain from different course depending on the days he spend on it.How to arrange the M days for the N courses to maximize the profit?

Input

The input consists of multiple data sets. A data set starts with a line containing two positive integers N and M, N is the number of courses, M is the days ACboy has. Next follow a matrix A[i][j], (1<=i<=N<=100,1<=j<=M<=100).A[i][j] indicates if ACboy spend j days on ith course he will get profit of value A[i][j]. N = 0 and M = 0 ends the input.

Output

For each data set, your program should output a line which contains the number of the max profit ACboy will gain.

Sample Input

代码语言:javascript
复制
   2 2
1 2
1 3
2 2
2 1
2 1
2 3
3 2 1
3 2 1
0 0

Sample Output

代码语言:javascript
复制
   3
4
6

Source

HDU 2007-Spring Programming Contest

题意:ACboy这学期有N门课程,他计划花最多M天去学习去学习这些课程,ACboy再第i天学习第j门课程的收益是不同的,求ACboy能获得的最大收益。

思路:分组背包,注意同一门课程之能选1次。

代码语言:javascript
复制
#include<stdio.h>
#include<string.h>
int wi[155][155];   //作用值
int vi[155][155];   //所花天数
int xx[111];
int n,m;
int f[3333];
int package()   //背包模版
{
    for(int i=0;i<=m;i++)
        f[i]=0;
    for(int j=0;j<n;j++)
    {
        for(int h=m;h>=0;h--)
        {
            for(int i=0;i<m;i++)
            {
                if(h-vi[j][i]>=0)
                    f[h]=f[h]>f[h-vi[j][i]]+wi[j][i]?f[h]:f[h-vi[j][i]]+wi[j][i];
            }
        }
    }
    return f[m];
}
int main()
{
    int i,j;
    int ans;
    while(scanf("%d%d",&n,&m)&&m&&n)
    {
        memset(vi,0,sizeof(vi));
        memset(wi,0,sizeof(wi));
        for(i=0;i<n;i++)
        {    
            for(j=0;j<m;j++)
            {
                vi[i][j]=j+1;
                scanf("%d",&wi[i][j]);
            }
        }
        ans=package();
        printf("%d\n",ans);
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Time Limit : 1000/1000ms (Java/Other)   Memory Limit : 32768/32768K (Java/Other)
  • Total Submission(s) : 158   Accepted Submission(s) : 74
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档