前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ACMSGURU 358 - Median of Medians

ACMSGURU 358 - Median of Medians

作者头像
Reck Zhang
发布2021-08-11 10:13:26
2930
发布2021-08-11 10:13:26
举报
文章被收录于专栏:Reck Zhang

Median of Medians

Problem Description

Vasya learned definition of median of three numbers. He says, “Median of three numbers is the number located in the middle when numbers are ordered in non-descending order”. Subtle Pete gave him much more difficult task. Vasya has to find median of each of three triples and then find the median of three numbers he found. Please help Vasya with the task.

Input

The input file contains three lines. Each line contains three integers. Each number is not less than -1000 and is not greater than 1000.

Output

Print one number - median of three medians.

Example(s)

sample input

sample output

6 4 57 9 81 2 3

5

sample input

sample output

1 2 24 3 22 3 4

3

Solution

代码语言:javascript
复制
#include <bits/stdc++.h>

int main() {
    std::ios::sync_with_stdio(false);

    std::vector<int> vec(3, 0);
    std::vector<int> final(3, 0);
    for(int i = 0; i < 3; i++) {
        for(int j = 0; j < 3; j++) {
            std::cin >> vec[j];
        }
        std::sort(vec.begin(), vec.end());
        final[i] = vec[1];
    }

    std::sort(final.begin(), final.end());

    std::cout << final[1] << std::endl;

    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019-10-28,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Median of Medians
    • Problem Description
      • Input
        • Output
          • Example(s)
            • Solution
            领券
            问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档