前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ACMSGURU 107 - 987654321 problem

ACMSGURU 107 - 987654321 problem

作者头像
Reck Zhang
发布2021-08-11 10:55:42
2120
发布2021-08-11 10:55:42
举报
文章被收录于专栏:Reck Zhang

987654321 problem

Problem Description

For given number N you must output amount of N-digit numbers, such, that last digits of their square is equal to 987654321.

Input

Input contains integer number N (1<=N<=106)

Output

Write answer to the output.

Sample Input

8

Sample Output

0

Solution

代码语言:javascript
复制
#include <bits/stdc++.h>

int main() {
    std::ios::sync_with_stdio(false);

    int n = 0;
    std::cin >> n;
    if(n <= 8) {
        std::cout << 0 << std::endl;
    } else if(n == 9) {
        std::cout << 8 << std::endl;
    } else {
        std::cout << 72;
        while(n---10) {
            std::cout << "0";
        }
        std::cout << std::endl;
    }

    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019-12-09,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 987654321 problem
    • Problem Description
      • Input
        • Output
          • Sample Input
            • Sample Output
              • Solution
              领券
              问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档