前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >ACMSGURU 112 - a^b-b^a

ACMSGURU 112 - a^b-b^a

作者头像
Reck Zhang
发布2021-08-11 11:12:21
5900
发布2021-08-11 11:12:21
举报
文章被收录于专栏:Reck Zhang

a^b-b^a

Problem Description

You are given natural numbers a and b. Find a^b-b^a.

Input

Input contains numbers a and b (1≤a,b≤100).

Output

Write answer to output.

Sample Input

2 3

Sample Output

-1

Solution

代码语言:javascript
复制
if __name__ == '__main__':

    x, y = map(int, input().split())

    def quick_pow(a, n):
        res = 1
        while n != 0:
            if n & 1:
                res *= a
            a *= a
            n >>= 1
        return res

    print(quick_pow(x, y) - quick_pow(y, x))
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2019-10-26,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • a^b-b^a
    • Problem Description
      • Input
        • Output
          • Sample Input
            • Sample Output
              • Solution
              领券
              问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档