前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PTA 1006 Sign In and Sign Out (25 分)

PTA 1006 Sign In and Sign Out (25 分)

原创
作者头像
freesan44
修改2021-09-24 14:11:57
2970
修改2021-09-24 14:11:57
举报
文章被收录于专栏:freesan44

题目

At the beginning of every day, the first person who signs in the computer room will unlock the door, and the last one who signs out will lock the door. Given the records of signing in's and out's, you are supposed to find the ones who have unlocked and locked the door on that day.

Input Specification:

Each input file contains one test case. Each case contains the records for one day. The case starts with a positive integer M, which is the total number of records, followed by M lines, each in the format:

ID_number Sign_in_time Sign_out_time

where times are given in the format HH:MM:SS, and ID_number is a string with no more than 15 characters.

Output Specification:

For each test case, output in one line the ID numbers of the persons who have unlocked and locked the door on that day. The two ID numbers must be separated by one space.

Note: It is guaranteed that the records are consistent. That is, the sign in time must be earlier than the sign out time for each person, and there are no two persons sign in or out at the same moment.

代码语言:txt
复制
Sample Input:
3
CS301111 15:30:28 17:00:10
SC3021234 08:00:00 11:25:25
CS301133 21:45:00 21:58:40
结尾无空行
Sample Output:
SC3021234 CS301133
结尾无空行

解题思路

代码语言:txt
复制
N = int(input())
# N = 3
def strToTimestamp(input:str) -> int:
    H,m,s = map(int,input.split(":"))
    res = H*3600 + m * 60 + s
    return res
resList = []
for _ in range(N):
    name,start,end = map(str,input().split())
    # name, start, end = map(str, "CS301111 15:30:28 17:00:10".split())
    resList.append([name,strToTimestamp(start),strToTimestamp(end)])
# print(resList)
resList.sort(key= lambda x:(x[1]))#根据开始时间排序,然后获取最低值的ID
#sorted(resList,key= lambda x:(x[1]))
# print(resList)
startNo = resList[0][0]
#sorted(resList,key= lambda x:(x[2]))
resList.sort(key= lambda x:(x[2]))#根据结束时间排序,然后获取最高值的ID
# print(resList)
endNo = resList[-1][0]
print(startNo,endNo)

原创声明:本文系作者授权腾讯云开发者社区发表,未经许可,不得转载。

如有侵权,请联系 cloudcommunity@tencent.com 删除。

原创声明:本文系作者授权腾讯云开发者社区发表,未经许可,不得转载。

如有侵权,请联系 cloudcommunity@tencent.com 删除。

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 题目
  • 解题思路
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档