前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >PAT(甲级)1036.Boys vs Girls(25)

PAT(甲级)1036.Boys vs Girls(25)

作者头像
lexingsen
发布2022-02-25 08:03:36
1800
发布2022-02-25 08:03:36
举报
文章被收录于专栏:乐行僧的博客

PAT 1036.Boys vs Girls(25) This time you are asked to tell the difference between the lowest grade of all the male students and the highest grade of all the female students.

输入格式: Each input file contains one test case. Each case contains a positive integer N, followed by N lines of student information. Each line contains a student’s name, gender, ID and grade, separated by a space, where name and ID are strings of no more than 10 characters with no space, gender is either F (female) or M (male), and grade is an integer between 0 and 100. It is guaranteed that all the grades are distinct.

输出格式: For each test case, output in 3 lines. The first line gives the name and ID of the female student with the highest grade, and the second line gives that of the male student with the lowest grade. The third line gives the difference grade​F−gradeM . If one such kind of student is missing, output Absent in the corresponding line, and output NA in the third line instead.

输入样例1:

代码语言:javascript
复制
3
Joe M Math990112 89
Mike M CS991301 100
Mary F EE990830 95

输出样例1:

代码语言:javascript
复制
Mary EE990830
Joe Math990112
6

输入样例2:

代码语言:javascript
复制
1
Jean M AA980920 60

输出样例1:

代码语言:javascript
复制
Absent
Jean AA980920
NA

题目分析:vector+排序,水题!。

AC代码:

代码语言:javascript
复制
#include <bits/stdc++.h>
using namespace std;

struct stu{
    string name;
    string id;
    int score;
};

vector<stu> female;
vector<stu> male;


bool cmpfemale(stu a, stu b){return a.score > b.score;}
bool cmpmale(stu a, stu b){return a.score < b.score;}
void print(stu a){
    cout<<a.name<<" "<<a.id<<" "<<a.score<<endl;
}

int main(){
    int n;
    scanf("%d", &n);
    string name,gender,id;
    int score;
    for(int i=0; i<n; ++i){
        cin>>name>>gender>>id;
        scanf("%d", &score);
        stu s;
        s.name = name;
        s.id = id;
        s.score = score;
        if(gender[0]=='M'){
            male.push_back(s);
        }
        else{
            female.push_back(s);
        }
    }
    sort(male.begin(), male.end(), cmpmale);
    sort(female.begin(), female.end(), cmpfemale);
    int maxScore, minScore;
    bool flag = false;
    if(female.size()!=0){
        cout<<female[0].name<<" "<<female[0].id<<endl;
        maxScore = female[0].score;
    }
    else{
        flag = true;
        cout<<"Absent"<<endl;
    }
    if(male.size()!=0){
        cout<<male[0].name<<" "<<male[0].id<<endl;
        minScore = male[0].score;
    }
    else{
        flag = true;
        cout<<"Absent"<<endl;
    }
    if(flag)
        cout<<"NA"<<endl;
    else
        cout<<maxScore-minScore<<endl;
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档