专栏首页Zabbix中国官方Zabbix版本兼容性

Zabbix版本兼容性

本文节选自《Zabbix监控系统之深度解析和实践》一书,有关参数举例参考等更多内容,欢迎阅读本书。

1.支持的AGENTS

从1.4版本开始,Zabbix agent与Zabbix 5.0兼容。但是,用户可能需要检查旧Zabbix agent的配置文件,因为可能会有一些参数的变动,如3.0以前版本的日志相关的参数与之前的不同。

想尝试新的功能和改进的监控项、性能,以及更小的内存使用,请使用最新的Zabbix 5.0 agent。

注意:更新于5.0的Zabbix agent不能与Zabbix server 5.0一起使用。

2. 支持的Zabbix proxies

Zabbix 5.0 proxies只支持与Zabbix 5.0 server一起工作。

这里值得注意一下,当升级完Zabbix server后,尚未升级的Zabbix proxies 无法向Zabbix server发送监控数据(Zabbix proxies无法刷新其配置)。

Zabbix官方之前不推荐使用低版本Zabbix proxy向高版本Zabbix server发送监控数据,现在官方正式禁用低版本Zabbix proxy向高版本Zabbix server发送监控数据,Zabbix server将忽略未升级的Zabbix proxy。

3. 支持的XML文件

Zabbix 5.0支持使用版本号为1.8、2.0、2.2、2.4、3.0、3.2、3.4、4.0、4.2和4.4的Zabbix导出的XML文件导入。

在Zabbix 1.8 XML导出格式中,触发器依赖项仅按名称存储。如果有几个具有相同名称(如具有不同的严重性和表达式)且在它们之间定义了依赖关系的触发器,则不可能被导入,必须手动从XML文件中删除这些依赖项,并在导入后重新添加。

本文节选自《Zabbix监控系统之深度解析和实践》一书,有关参数举例参考等更多内容,欢迎阅读本书

文章分享自微信公众号:
Zabbix开源社区

本文参与 腾讯云自媒体分享计划 ,欢迎热爱写作的你一起参与!

作者:Zabbix开源社区
原始发表时间:2022-04-13
如有侵权,请联系 cloudcommunity@tencent.com 删除。
登录 后参与评论
0 条评论

相关文章

  • Hadoop、Hbase、Hive版本兼容性

    当我们想整合hadoop,hbase,hive,zookeeper的时候,如果刚入门,可能认为这是比较简单的问题。但是当你自己真正想整合的时候,却会遇到很多的问...

    Albert陈凯
  • Zabbix 5.0 LTS 版本安装

    zabbix 5.0 版本于 5 月 11 日正式发布,是最新的 LTS(长期支持)版本,5.0 带来很多功能和特性,后面会陆续推出文章介绍,下面主要介绍下 5...

    Kevin song
  • webpack 中版本兼容性问题错误总结

    一定不要运行npm i  XXX  -g(-d) 一定要指定版本,尽量低版本,也不最新版本,会导致不兼容和指令不一样的问题。

    李文杨
  • JanusGraph各组件版本兼容性匹配表

    https://docs.janusgraph.org/latest/version-compat.html

    陈黎栋
  • zabbix4.2版本安装

     版权声明:署名,允许他人基于本文进行创作,且必须基于与原先许可协议相同的许可协议分发本文 (Creative Commons)

    拓荒者
  • zabbix4.2版本安装

     版权声明:署名,允许他人基于本文进行创作,且必须基于与原先许可协议相同的许可协议分发本文 (Creative Commons)

    拓荒者
  • 数据库PostrageSQL-版本和平台兼容性

    array_nulls (boolean) 这个参数控制数组输入解析器是否把未用引号的NULL识别为一个空数组元素。默认为on,允许输入包含空值的数组值。但是...

    cwl_java
  • vue低版本浏览器兼容性(20181224更新)

    金子村村草
  • zabbix5.0LTS版本server与proxy安装

    ####################可访问外网的相同环境的机器进行如下操作####################

    Bob hadoop
  • 离线rpm包安装zabbix5.0 LTS版本

    经过了两个月的休息,开始了新的工作,zabbix之前有接触,但是不深,后面会着重的学习并分享。

    Bob hadoop
  • zabbix5.0 LTS版本部署(MySQL-Apache)

    编辑配置文件 /etc/yum.repos.d/zabbix.repo 并启用 zabbix-frontend。

    用户6914340
  • Zabbix 5.0.0beta1版本初体验

    Zabbix 5.0.0beta1 版本开始前端需要使用PHP 7.2以上的版本,目前使用的Centos 7 仅提供PHP 5.4,Zabbix 官方...

    没有故事的陈师傅
  • Zabbix5.0版本Agent2安装

    Zabbix 5.0 版本推出了使用 go 语言重写的 Agent2,也是 5.0 版本新特性,Agent2 有如下特性:

    Kevin song
  • hadoop,hbase,hive,zookeeper版本整合兼容性最全,最详细说明【适用于任何版本】

    问题导读 1.hadoop与hbase哪些版本兼容? 2.hadoop与hive哪些版本兼容? 3.hbase与hive哪些版本兼容? 4.hbase与zook...

    用户1410343
  • ZABBIX 升级 (ZABBIX Server + ZABBIX Proxy)

    (1)由于生产环境采用NGINX ,ZABBIX Server默认使用HTTP,升级后的文件默认存放在usr/share/zabbix,需要拷贝到Nginx ...

    Kevin song
  • Centos7系统安装Zabbix 5.0LTS版本教程

    Zabbix官网https://www.zabbix.com/ (英文版) https://www.zabbix.com/cn/ (中文版)

    用户1094633
  • CentOS 8.0.1905 安装 ZABBIX4.4版本 (已验证)

    版本:ZABBIX版本4.4 系统:CentOS8.0.1905 数据库:Mysql-server-8.0.17

    砸漏
  • 新版本系统适配: Android 12 中的兼容性变更

    随着 Android 12 正式版 的发布,越来越多的用户将升级至最新版本。Android 12 带来大量新 API 和功能更新的同时也带来了平台兼容性的变更,...

    Android 开发者
  • Android高版本API方法如何在低版本系统上做兼容性处理浅析

    但是报错了Call requires API level 24 (current min is 21): android.telephony.Telephony...

    砸漏

扫码关注腾讯云开发者

领取腾讯云代金券