前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >精彩编码 【进制转换】

精彩编码 【进制转换】

作者头像
全栈程序员站长
发布2022-07-06 11:22:27
1.2K0
发布2022-07-06 11:22:27
举报
文章被收录于专栏:全栈程序员必看

大家好,又见面了,我是全栈君。

精彩编码 Description 如果没有阿拉伯数字,我们想得到怎样来表示数字 小明觉得一个方法,如下面的: 1 -> A 2 -> B 3 -> C …. 25 -> Y 26 -> Z 27 -> AA

28 -> AB ….

如今请你写一个程序完毕这个转换

Input 输入的第一个数为一个正整数T,表明接下来有T组数据。 每组数据为一个正整数n ( n <= 1000)

Output 对于每一个正整数n,输出他相应的字符串

Sample Input 3 1 10 27 Sample Output A J AA

进制转换?

代码语言:javascript
复制
#include <stdio.h> 
#include <iostream> 
#include <math.h> 
#include <stdlib.h> 
#include <ctype.h> 
#include <algorithm> 
#include <vector> 
#include <string.h> 
#include <queue> 
#include <stack> 
#include <set> 
#include <sstream> 
#include <time.h> 
#include <utility> 
#include <malloc.h> 
#include <stdexcept> 
#include <iomanip> 
#include <iterator> 

using namespace std;

int main()
{
    int n,t;
    scanf("%d",&t);
    while (t--)
    {
        scanf("%d",&n);
        if (n <= 26)
            printf("%c\n", 'A' + n - 1);
        else if (n <= 26 * 26 + 26)
        {
            n -= 27;
            int t = n / 26;
            printf("%c", 'A' + t);
            n = n % 26;
            printf("%c\n", 'A' + n);
        }
        else
        {
            n -= 27 + 26 * 26;
            printf("%c%c%c\n", 'A' + char(n / 26 / 26), 'A' + char((n / 26) % 26), 'A' + char(n % 26));
        }
    }
    return 0;
}

版权声明:转载请注明出处。

发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/117143.html原文链接:https://javaforall.cn

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2022年1月1,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档