前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >【二分搜索】最大化最小值:POJ2456

【二分搜索】最大化最小值:POJ2456

作者头像
灯珑LoGin
发布2022-10-31 14:28:14
2600
发布2022-10-31 14:28:14
举报
文章被收录于专栏:龙进的专栏

题目:POJ2456

代码语言:javascript
复制
Aggressive cows
Time Limit: 1000MS		Memory Limit: 65536K
Total Submissions: 36441		Accepted: 16640
Description

Farmer John has built a new long barn, with N (2 <= N <= 100,000) stalls. The stalls are located along a straight line at positions x1,...,xN (0 <= xi <= 1,000,000,000).

His C (2 <= C <= N) cows don't like this barn layout and become aggressive towards each other once put into a stall. To prevent the cows from hurting each other, FJ want to assign the cows to the stalls, such that the minimum distance between any two of them is as large as possible. What is the largest minimum distance?
Input

* Line 1: Two space-separated integers: N and C

* Lines 2..N+1: Line i+1 contains an integer stall location, xi
Output

* Line 1: One integer: the largest minimum distance
Sample Input

5 3
1
2
8
4
9
Sample Output

3
Hint

OUTPUT DETAILS:

FJ can put his 3 cows in the stalls at positions 1, 4 and 8, resulting in a minimum distance of 3.

Huge input data,scanf is recommended.
Source

USACO 2005 February Gold

这种最大化最小值或者最小化最大值的问题,通常可以使用二分搜索解决。

我们定义条件:可以安排牛的位置使得最近两头牛的距离不小于d

然后就通过二分搜索的方式,求解出满足条件的最小的d,就是答案了。

AC代码

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
using namespace std;
typedef long long ll;

#define MAXN 100005

int n, c;
ll x[MAXN];

bool check(ll d)
{
    int tmpc = c - 1;
    int i = 1;
    ll last_pos = x[0];
    while (tmpc && i < n)
    {
        if (last_pos + d <= x[i])
        {
            //当前牛舍放牛
            --tmpc;
            last_pos = x[i];
        }
        ++i;
    }
    if (tmpc)
        return false;
    else
        return true;
}

void solve()
{
    ll l = 0, r = 1e9 + 7;
    ll mid;
    while (l+1< r)
    {
        mid = ((l + r) >> 1);
        if (check(mid))
        {
            l = mid;
        }
        else
            r = mid;
            
    }
    printf("%lld\n", l);
}

int main()
{
    scanf("%d%d", &n, &c);
    for (int i = 0; i < n; ++i)
    {
        scanf("%lld", &x[i]);
    }

    sort(x, x + n);
    solve();
}

转载请注明来源:https://www.longjin666.top/?p=1185

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2021年9月9日20,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • AC代码
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档