前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >C语言-链表排序_单链表的排序c语言

C语言-链表排序_单链表的排序c语言

作者头像
全栈程序员站长
发布2022-11-07 16:34:09
4.8K0
发布2022-11-07 16:34:09
举报
文章被收录于专栏:全栈程序员必看

大家好,又见面了,我是你们的朋友全栈君。

C语言-链表排序

题目描述

已有a、b两个链表,每个链表中的结点包括学号、成绩。要求把两个链表合并,按学号升序排列。

输入

第一行,a、b两个链表元素的数量N、M,用空格隔开。 接下来N行是a的数据 然后M行是b的数据 每行数据由学号和成绩两部分组成

输出

按照学号升序排列的数据

样例输入

2 3 5 100 6 89 3 82 4 95 2 10

样例输出

2 10 3 82 4 95 5 100 6 89

My first try on Linkedlist, quite hard for me at first especially the beginning part also pointer is a hard part for I havn’t understood yet BUT PRACTICE PAYS I finally get to know it

代码语言:javascript
复制
#include<cstdio>
#include<cstdlib>
typedef struct student{ 
//定义结构 
int num;
int sco;
struct student *next;
}stu;
stu *creat(int n){ 
//创建链表 
stu *head,*node,*end;
head=(stu*)malloc(sizeof(stu));
end=head;
for(int i=0;i<n;i++){ 

node=(stu*)malloc(sizeof(stu));
scanf("%d %d",&node->num,&node->sco);
end->next=node;
end=node;
}
end->next=NULL;
return head;
}
stu *link(stu *a,stu*b)//链接 
{ 

stu *p=a;
while(p->next!=NULL){ 

p=p->next;
}
p->next=b->next;
return a;
}
void linksort(struct student *p){ 
//排序 
int tnum,tsco,k=0,i=1;
struct student *p1;
p1=p;
while(i!=0){ 

while(p1->next!=NULL){ 

if(p1->num>p1->next->num)  { 

tnum=p1->num;
p1->num=p1->next->num;
p1->next->num=tnum;
tsco=p1->sco;
p1->sco=p1->next->sco;
p1->next->sco=tsco;
k++;
}
p1=p1->next;
}
p1=p;
if(k>0){ 

k=0;
}
else i=0;
}
}
void print(stu *a)//输出 
{ 

stu *p=a;
while(p->next!=NULL){ 

printf("%d %d\n",p->num,p->sco);
p=p->next;
}
}
int main()
{ 

int n,m;
scanf("%d %d",&n,&m);
stu *a=creat(n);
stu *b=creat(m);
stu *p=link(a,b);
linksort(p);
print(p);
return 0;
} 

版权声明:本文内容由互联网用户自发贡献,该文观点仅代表作者本人。本站仅提供信息存储空间服务,不拥有所有权,不承担相关法律责任。如发现本站有涉嫌侵权/违法违规的内容, 请发送邮件至 举报,一经查实,本站将立刻删除。

发布者:全栈程序员栈长,转载请注明出处:https://javaforall.cn/183087.html原文链接:https://javaforall.cn

本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2022年10月11日,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • C语言-链表排序
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档