前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Break Standard Weight (ZOJ 3706)

Break Standard Weight (ZOJ 3706)

作者头像
Lokinli
发布2023-03-09 16:14:50
1340
发布2023-03-09 16:14:50
举报
文章被收录于专栏:以终为始

Problem

The balance was the first mass measuring instrument invented. In its traditional form, it consists of a pivoted horizontal lever of equal length arms, called the beam, with a weighing pan, also called scale, suspended from each arm (which is the origin of the originally plural term "scales" for a weighing instrument). The unknown mass is placed in one pan, and standard masses are added to this or the other pan until the beam is as close to equilibrium as possible. The standard weights used with balances are usually labeled in mass units, which are positive integers.

With some standard weights, we can measure several special masses object exactly, whose weight are also positive integers in mass units. For example, with two standard weights 1 and 5, we can measure the object with mass 145 or 6 exactly.

In the beginning of this problem, there are 2 standard weights, which masses are xand y. You have to choose a standard weight to break it into 2 parts, whose weights are also positive integers in mass units. We assume that there is no mass lost. For example, the origin standard weights are 4 and 9, if you break the second one into 4and 5, you could measure 7 special masses, which are 1, 3, 4, 5, 8, 9, 13. While if you break the first one into 1 and 3, you could measure 13 special masses, which are 1, 2, 3, 4, 5, 6, 7, 8, 9, 10, 11, 12, 13! Your task is to find out the maximum number of possible special masses.

Input

There are multiple test cases. The first line of input is an integer T < 500 indicating the number of test cases. Each test case contains 2 integers x and y. 2 ≤ xy ≤ 100

Output

For each test case, output the maximum number of possible special masses.

Sample Input

代码语言:javascript
复制
2
4 9
10 10

Sample Output

代码语言:javascript
复制
13
9

题解:直接枚举暴力所有情况,比较那种拆法多就可以了。

代码语言:javascript
复制
#include <iostream>
#include <algorithm>
#include <cstdio>
#include <cstdlib>
#include <cstring>
#include <cmath>
using namespace std;
typedef long long ll;
int a[520], vis[505] = {0};
int f(int a, int b, int c)
{
    memset(vis, 0, sizeof(vis));
    int x = a;
    int ans = 0;

    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
     x = b;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
     x = c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
     x = a + b + c;

    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = a + b -c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = a - b +c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = a - b -c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = -a + b +c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = -a + b -c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = -a - b +c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}

    x = a + b;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = a - b;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = b - a;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}

    x = c + b;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = c - b;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = b - c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}

    x = a + c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = a - c;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    x = c - a;
    if(x > 0 && vis[x] == 0){vis[x] = 1;ans++;}
    return ans;

}
int main()
{
    int t,i,n,ans,m,j, xx = 0;
    while(scanf("%d", &t) != EOF)
    {
        while(t--)
        {
            xx = 0;
            scanf("%d %d", &n, &m);
            for(i = 1; i <= n/2; i++)
            {
                ans = f(i, n - i, m);
                xx = max(ans, xx);
            }
            for(i = 1; i <= m/2; i++)
            {
                ans = f(i, m - i, n);
                xx = max(ans, xx);
            }
            printf("%d\n", xx);
        }
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2018-08-06,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档