前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Friend-Graph (HDU 6152)2017中国大学生程序设计竞赛 - 网络选拔赛

Friend-Graph (HDU 6152)2017中国大学生程序设计竞赛 - 网络选拔赛

作者头像
Lokinli
发布2023-03-09 16:28:10
2400
发布2023-03-09 16:28:10
举报
文章被收录于专栏:以终为始以终为始

Problem Description

It is well known that small groups are not conducive of the development of a team. Therefore, there shouldn’t be any small groups in a good team. In a team with n members,if there are three or more members are not friends with each other or there are three or more members who are friends with each other. The team meeting the above conditions can be called a bad team.Otherwise,the team is a good team. A company is going to make an assessment of each team in this company. We have known the team with n members and all the friend relationship among these n individuals. Please judge whether it is a good team.

Input

The first line of the input gives the number of test cases T; T test cases follow.(T<=15) The first line od each case should contain one integers n, representing the number of people of the team.(n≤3000) Then there are n-1 rows. The ith row should contain n-i numbers, in which number aij represents the relationship between member i and member j+i. 0 means these two individuals are not friends. 1 means these two individuals are friends.

Output

Please output ”Great Team!” if this team is a good team, otherwise please output “Bad Team!”.

Sample Input

1    4       1 1 0     0 0   1

Sample Output

Great Team!

题解:Team中有3个或者3个以上不是朋友或者是朋友,都输出Bad,其他输出Great。

代码语言:javascript
复制
/** By Mercury_Lc */
#include <bits/stdc++.h>
using namespace std;
int a[3005][3005];
int main()
{
    int t,i,j,k,n,f;
    scanf("%d",&t);
    while(t--)
    {
        f = 0;
        scanf("%d",&n);
        for(i = 1; i <= n; i ++)
        {
            for(j = i + 1; j <= n; j ++)
            {
                scanf("%d",&a[i][j]);
            }
        }
        for(i = 1; i <= n; i ++)     //暴力搜索
        {
            for(j = i + 1; j <= n; j ++)
            {
                if(a[i][j])          // 是朋友关系,继续判断这两个人有没有共同朋友
                {
                    for(k = j + 1; k <= n; k ++)
                    {
                        if(a[i][k] && a[j][k])
                        {
                            f = 1;
                            break;
                        }
                    }
                }
                else           // 不是朋友关系,继续判断这两个人有没有共同朋友
                {
                    for(k =  j + 1; k <= n; k ++)   
                    {
                        if(a[i][k] == 0 && a[j][k] == 0)
                        {
                            f = 1;
                            break;
                        }
                    }
                }
                if(f)break;
            }
            if(f)break;
        }
        if(f)printf("Bad Team!\n");
        else printf("Great Team!\n");
    }
    return 0;
}
本文参与 腾讯云自媒体分享计划,分享自作者个人站点/博客。
原始发表:2018-08-24,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体分享计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • Problem Description
  • Input
  • Output
  • Sample Input
  • Sample Output
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档