前往小程序,Get更优阅读体验!
立即前往
首页
学习
活动
专区
工具
TVP
发布
社区首页 >专栏 >Til the Cows Come Home ( POJ 2387) (简单最短路 Dijkstra)

Til the Cows Come Home ( POJ 2387) (简单最短路 Dijkstra)

作者头像
Lokinli
发布2023-03-09 16:58:54
1770
发布2023-03-09 16:58:54
举报
文章被收录于专栏:以终为始

problem

Bessie is out in the field and wants to get back to the barn to get as much sleep as possible before Farmer John wakes her for the morning milking. Bessie needs her beauty sleep, so she wants to get back as quickly as possible. Farmer John's field has N (2 <= N <= 1000) landmarks in it, uniquely numbered 1..N. Landmark 1 is the barn; the apple tree grove in which Bessie stands all day is landmark N. Cows travel in the field using T (1 <= T <= 2000) bidirectional cow-trails of various lengths between the landmarks. Bessie is not confident of her navigation ability, so she always stays on a trail from its start to its end once she starts it. Given the trails between the landmarks, determine the minimum distance Bessie must walk to get back to the barn. It is guaranteed that some such route exists.

Input

* Line 1: Two integers: T and N * Lines 2..T+1: Each line describes a trail as three space-separated integers. The first two integers are the landmarks between which the trail travels. The third integer is the length of the trail, range 1..100.

Output

* Line 1: A single integer, the minimum distance that Bessie must travel to get from landmark N to landmark 1.

Sample Input

代码语言:javascript
复制
5 5
1 2 20
2 3 30
3 4 20
4 5 20
1 5 100

Sample Output

代码语言:javascript
复制
90

Hint

INPUT DETAILS: There are five landmarks. OUTPUT DETAILS: Bessie can get home by following trails 4, 3, 2, and 1.

 题解:简单的最短路,板子题,一遍Dijkstra。

代码语言:javascript
复制
#include <iostream>
#include <cstdio>
#include <cstdlib>
#include <algorithm>
#include <cstring>
using namespace std;
int m,n;
const int inf = 0x3f3f3f3f;
int dis[1005];
int gra[1005][1005];
int vis[1005];
void dj()
{
    memset(vis,0,sizeof(vis));
    int minn,v;
    for(int i = 1; i <= n; i ++) dis[i] = gra[1][i];
    for(int i = 1; i <= n; i ++)
    {
        minn = inf;
        for(int j = 1; j <= n; j ++)
        {
            if(!vis[j] && dis[j] < minn)
            {
                minn = dis[j];
                v = j;
            }
        }
        vis[v] = 1;
        for(int j = 1; j <= n; j ++)
        {
            if(gra[v][j] + dis[v] < dis[j] && !vis[j])
            {
                dis[j] = gra[v][j] + dis[v];
            }
        }
    }
    printf("%d\n",dis[n]);
}
int main()
{
    int i,j,a,b,c;
    while(~scanf("%d%d",&m,&n))
    {
        for(i = 1; i <= n; i ++)
        {
            for(j = 1; j <= n; j ++)
            {
                if(i == j) gra[i][j] = 0;
                else gra[i][j] = gra[j][i] = inf;
            }
        }
        for(i = 1; i <= m; i ++)
        {
            scanf("%d%d%d",&a,&b,&c);
            if(gra[a][b] > c ) gra[a][b] = gra[b][a] = c;
        }
        dj();
    }
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2018-10-19,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档