前往小程序,Get更优阅读体验!
立即前往
发布
社区首页 >专栏 >试题 算法训练 最长字符串

试题 算法训练 最长字符串

作者头像
GeekLiHua
发布2025-01-21 14:33:59
发布2025-01-21 14:33:59
4900
代码可运行
举报
文章被收录于专栏:Java
运行总次数:0
代码可运行

试题 算法训练 最长字符串

资源限制 内存限制:512.0MB C/C++时间限制:1.0s Java时间限制:3.0s Python时间限制:5.0s   求出5个字符串中最长的字符串。每个字符串长度在100以内,且全为小写字母。 样例输入 one two three four five 样例输出 three

提交代码

代码语言:javascript
代码运行次数:0
复制
#include <stdlib.h>
#include <stdio.h>
#include <algorithm>
#include <iostream>
#include <string.h>
#include <math.h>
using namespace std;
char a[5][105];
int main()
{
	int max=0,ans=0;
	for(int i=0;i<5;i++)
	{
		scanf("%s",a[i]);
		if(max<strlen(a[i]))
		{
			max=strlen(a[i]);
			ans=i;
		}
	}
	cout<<a[ans]<<endl;
    return 0;
}
本文参与 腾讯云自媒体同步曝光计划,分享自作者个人站点/博客。
原始发表:2025-01-20,如有侵权请联系 cloudcommunity@tencent.com 删除

本文分享自 作者个人站点/博客 前往查看

如有侵权,请联系 cloudcommunity@tencent.com 删除。

本文参与 腾讯云自媒体同步曝光计划  ,欢迎热爱写作的你一起参与!

评论
登录后参与评论
0 条评论
热度
最新
推荐阅读
目录
  • 试题 算法训练 最长字符串
领券
问题归档专栏文章快讯文章归档关键词归档开发者手册归档开发者手册 Section 归档