学习路线:C++智能指针shared_ptr->C++智能指针unique_ptr->C++智能指针weak_ptr
简介:本文讲解常用的智能指针的用法和原理,包括shared_ptr
,unique_ptr
,weak_ptr
。
shared_ptr
(共享指针),对于同一个Object
,共享指针会记录有多少个指针指向同一个物体,当指向Object
的指针计数为0的时候,Object
对象就会释放,省去了delete
的烦恼。
#include<memory> // 引入头文件
using namespace std;
// 方式一 推荐
shared_ptr<int> p = make_shared<int>(100);
// 方式二
shared_ptr<int> p = new int(100);
学习代码
#include<memory>
#include<iostream>
using namespace std;
class Ball
{
public:
Ball(){
cout << "A ball construct." << endl;
}
~Ball(){
cout << "A ball disconstruct" << endl;
}
void Jump(){
cout << "A ball jump" << endl;
}
};
int main()
{
shared_ptr<Ball> p = make_shared<Ball>();
cout << p.use_count() << endl;
shared_ptr<Ball> p2 = p;
cout << p.use_count() << " " << p2.use_count() << endl;
shared_ptr<Ball> p3 = p;
cout << p.use_count() << " " << p2.use_count() << " "
<< p3.use_count() << endl;
p.reset();
p2.reset();
p3.reset();
return 0;
}
运行结果:
分析结果可知:
当指向最开始的对象Ball
的指针都释放了之后,那么最开始的对象Ball
也会被释放。
一共有 n 个数,编号是 1∼n,最开始每个数各自在一个集合中。
现在要进行 m 个操作,操作共有两种:
M a b,将编号为 a 和 b 的两个数所在的集合合并,如果两个数已经在同一个集合中,则忽略这个操作;
Q a b,询问编号为 a 和 b 的两个数是否在同一个集合中;
输入格式
第一行输入整数 n 和 m。
接下来 m 行,每行包含一个操作指令,指令为 M a b 或 Q a b 中的一种。
输出格式
对于每个询问指令 Q a b,都要输出一个结果,如果 a 和 b 在同一集合内,则输出 Yes,否则输出 No。
每个结果占一行。
数据范围
1≤n,m≤105
输入样例:
4 5
M 1 2
M 3 4
Q 1 2
Q 1 3
Q 3 4
输出样例:
Yes
No
Yes
提交代码
#include<iostream>
using namespace std;
const int N = 100010;
int n, m;
int p[N];
int find(int x) // 找到x的祖先节点
{
if (p[x] != x) p[x] = find(p[x]);
return p[x];
}
int main()
{
scanf("%d %d", &n, &m);
for (int i = 1; i <= n; ++i) p[i] = i;
while (m--)
{
char op;
int a, b;
scanf (" %c%d%d", &op, &a, &b);
if (op == 'M') p[p[find(a)]] = find(b); // 让a的祖先节点指向b的祖先节点
else
{
if (find(a) == find(b)) puts("Yes");
else puts("No");
}
}
return 0;
}
import java.io.*;
public class Main
{
static int N = 100010;
static int n, m;
static int [] p = new int [N];
static int find(int x)
{
if (p[x] != x) p[x] = find(p[x]);
return p[x];
}
public static void main(String[] args) throws IOException
{
BufferedReader reader = new BufferedReader(new InputStreamReader (System.in));
String [] str = reader.readLine().split(" ");
n = Integer.parseInt(str[0]);
m = Integer.parseInt(str[1]);
for (int i = 1; i <= n; ++ i) p[i] = i;
while (m -- > 0)
{
String op;
int a, b;
str = reader.readLine().split(" ");
op = str[0];
a = Integer.parseInt(str[1]);
b = Integer.parseInt(str[2]);
if (op.equals("M")) p[find(a)] = find(b);
else
{
if (find(a) == find(b)) System.out.println("Yes");
else System.out.println("No");
}
}
}
}