将R版本从3.0.3更新到3.1.2?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (238)

我想用ubuntu从3.0.3更新到3.1.2。我正在研究Ubuntu 14.04LTS,64位。

我做了以下几点:

cd /etc/apt/
sudo gedit sources.list

我添加了以下行:

deb http://cran.rstudio.com/bin/linux/ubuntu trusty/

然后 :

sudo apt-key adv --keyserver keyserver.ubuntu.com --recv-keys E084DAB9
sudo apt-get update
sudo apt-get upgrade
sudo apt-get install r-base

有些文件已上传。

然后我检查了R版本:

sudo R
version

platform       x86_64-unknown-linux-gnu    
arch           x86_64                      
os             linux-gnu                   
system         x86_64, linux-gnu           
status                                     
major          3                           
minor          0.3                         
year           2014                        
month          03                          
day            06                          
svn rev        65126                       
language       R                           
version.string R version 3.0.3 (2014-03-06)
nickname       Warm Puppy      

我仍然有3.0.3版本,有人可以帮我升级到3.1.2吗?

编辑ECII:

sudo apt-get dist-upgrade

Reading package lists... Done
Building dependency tree       
Reading state information... Done
The following packages were automatically installed and are no longer required:
blcr-util bwidget gcc-4.8-base:i386 ggobi jags libaudio2:i386 libcr0
libexpat1:i386 libffi6:i386 libfontconfig1:i386 libfreetype6:i386
libgcrypt11:i386 libgl1-mesa-glx:i386 libglapi-mesa:i386 libglib2.0-0:i386
libglpk36 libgpg-error0:i386 libgstreamer-plugins-base1.0-0:i386
libgstreamer1.0-0:i386 libhwloc5 libibverbs1 libice6:i386 libjbig0:i386
libjpeg-turbo8:i386 libjpeg8:i386 libodbc1 libopenmpi1.6 liborc-0.4-0:i386
libqt4-dbus:i386 libqt4-declarative:i386 libqt4-network:i386
libqt4-opengl:i386 libqt4-script:i386 libqt4-sql:i386 libqt4-xml:i386
libqt4-xmlpatterns:i386 libqtcore4:i386 libqtdbus4:i386 libqtgui4:i386
libqtwebkit4:i386 libquantlib-1.2 libsm6:i386 libsprng2 libsqlite3-0:i386
libssl1.0.0:i386 libstdc++6:i386 libtiff4 libtiff5:i386 libtk8.5 libtorque2
libx11-6:i386 libx11-xcb1:i386 libxau6:i386 libxcb-dri2-0:i386
libxcb-dri3-0:i386 libxcb-glx0:i386 libxcb-present0:i386 libxcb-sync1:i386
libxcb1:i386 libxdamage1:i386 libxdmcp6:i386 libxext6:i386 libxfixes3:i386
libxi6:i386 libxml2:i386 libxrender1:i386 libxshmfence1:i386 libxslt1.1:i386
libxss1:i386 libxt6:i386 libxv1:i386 libxxf86vm1:i386
linux-headers-3.13.0-35 linux-headers-3.13.0-35-generic
linux-image-3.11.0-26-generic linux-image-3.13.0-35-generic
linux-image-extra-3.11.0-26-generic linux-image-extra-3.13.0-35-generic lynx
mpi-default-bin openmpi-bin openmpi-checkpoint openmpi-common skype-bin:i386
tk-table tk8.5 unixodbc

编辑cd​​eterman:

sudo apt-key list
/etc/apt/trusted.gpg
--------------------
pub   1024D/437D05B5 2004-09-12
uid                  Ubuntu Archive Automatic Signing Key <ftpmaster@ubuntu.com>
sub   2048g/79164387 2004-09-12

pub   1024D/FBB75451 2004-12-30
uid                  Ubuntu CD Image Automatic Signing Key <cdimage@ubuntu.com>

pub   4096R/C0B21F32 2012-05-11
uid                  Ubuntu Archive Automatic Signing Key (2012) <ftpmaster@ubuntu.com>

pub   4096R/EFE21092 2012-05-11
uid                  Ubuntu CD Image Automatic Signing Key (2012) <cdimage@ubuntu.com>

pub   1024D/3E5C1192 2010-09-20
uid                  Ubuntu Extras Archive Automatic Signing Key <ftpmaster@ubuntu.com>

pub   1024R/579F147D 2010-04-25
uid                  Launchpad RKWard Development Archive

pub   2048R/E084DAB9 2010-10-19 [expire : 2015-10-18]
uid                  Michael Rutter <marutter@gmail.com>
sub   2048R/1CFF3E8F 2010-10-19 [expire : 2015-10-18]
提问于
用户回答回答于

好的,我修改正常了。

在突触包管理器中,我看到R-3.1.2安装在以下目录中(并且可执行文件名为R):/ usr / lib / R / bin / R

当我输入时

which R

它返回:

/usr/local/bin/R

所以R的来源与更新的不一样。我刚刚复制了新的可执行文件(usr/lib/R/bin/ in the good directory /usr/local/bin)。

热门问答

怎么关闭域名隐私保护?

推荐
根据 ICANN 《通用顶级域名注册数据临时政策细则(Temporary Specification for gTLD Registration Data)》和欧盟《通用数据保护条例》合规要求,腾讯云域名信息(WHOIS)查询结果中将不再展示域名所有者、所有者联系邮箱等信息。鉴于...... 展开详请

php发送smtp邮件失败,请帮忙看是腾讯云不支持端口25么?

SQL GM热爱数据库的小工匠
推荐
腾讯云默认限制 TCP:25 端口,支持解封,但是有注意事项: 仅支持解封预付费包年包月的云服务器,暂不支持按量付费的云服务器。 每个腾讯云账号仅可解封5个实例。 请确保 TCP 25端口仅用于连接第三方 SMTP 服务器,并从第三方 SMTP 服务器外发邮件。如发现您直接通过云...... 展开详请

设置了云函数环境变量TZ 为 asia/shanghai,云函数端仍是0时区日期,为何不生效?

Mason-Serverless

腾讯 · 产品经理 (已认证)

推荐
设置 TZ=Asia/Shanghai 可以获取到北京时间 image.png image.png image.png ... 展开详请

安卓APP使用免费版加固后,在Android11系统上运行闪退,是什么原因?

hello,目前已经适配了Android R Beta1,预计这周内上线移动应用安全在线版,请留意日志更新

serverless db 如何管理?

Richel码农
推荐
1.支持pg_dump,psql工具进行数据导入和导出。 2.本地CLI,可以使用postgresql的客户端psql,也可以使用dbeavr,navicate,pgadmin等工具访问。 3.支持操作DB ,要自己写逻辑 ... 展开详请

扩展能力之云调用,小程序端出错:[tcb-js-sdk]参数错误:非法的应用标识?

software微软、谷歌、腾讯、阿里、百度……
推荐
您好,appSign必须是小程序的appid,appSecret的两个字段必须是在云开发控制台-安全来源里配置过的。 image.png ... 展开详请

所属标签

扫码关注云+社区

领取腾讯云代金券