如何安装最新版本的gmsh?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (392)

如何在ubuntu16.04LTS上安装最新版本的gmsh,即gmsh 3.0.7?

我使用sudo apt install gmsh只能安装gmsh 2.10.1。我也更新和升级了我的系统,但仍然只有2.10.1版本。

有什么建议吗?

提问于
用户回答回答于

卸载存储库版本:

sudo apt-get remove gmsh

从gmsh网站下载Linux最新稳定版本的压缩副本。

解压缩gmsh:

tar -xvzf gmsh-3.0.6-Linux64.tgz(或下载的任何版本)

这使得包含gmsh的文件夹gmsh-3.0.6-Linux 64是可移植的。把它放在你能找到的地方。导航到bin文件夹:

cd ~/gmsh-3.0.6-Linux64/bin

在bin文件夹中,你可以通过键入以下命令启动gmsh:

./gmsh

我通过编辑.bashrc使它在命令行中通常可用,并添加了以下行:

export PATH="$PATH:/home/bob/gmsh-3.0.6-Linux64/bin"

你需要使路径适合你的位置。

所属标签

可能回答问题的人

  • 爸爸

    腾讯 · 客户端安全 (已认证)

    4 粉丝4 提问5 回答
  • 找虫虫

    0 粉丝0 提问5 回答
  • 不吃貓的鱼oo

    5 粉丝466 提问4 回答
  • uncle_light

    5 粉丝518 提问4 回答

扫码关注云+社区

领取腾讯云代金券