“org.jvnet.jaxb2.maven2”maven插件在eclipse中出现了错误?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (443)

我想使用“org.jvnet.jaxb2.maven2”maven插件从Web服务生成类。

Execution default of goal org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.12.3:generate failed: 
A required class was missing while executing org.jvnet.jaxb2.maven2:maven-jaxb2-plugin:0.12.3:generate: com/sun/xml/bind/api/ErrorListener

下面是POM片段:

<plugin>
    <groupId>org.jvnet.jaxb2.maven2</groupId>
    <artifactId>maven-jaxb2-plugin</artifactId>
    <version>0.12.3</version>
    <executions>
        <execution>
            <goals>
                <goal>generate</goal>
            </goals>
        </execution>
    </executions>
    <configuration>
        <schemaLanguage>WSDL</schemaLanguage>
        <generatePackage>fpcy.wsdl</generatePackage>
        <schemas>
            <schema>
                <url>{the web sevice url}</url>
            </schema>
        </schemas>
    </configuration>
</plugin>

和jre配置:

​但是如何将这个类添加到我的项目中呢?

提问于
用户回答回答于

我找到了解决它的方法:将jaxb插d从“maven-jaxb2-plugin”更改为“maven-jaxb20-plugin”。请参阅:https://github.com/highsource/maven-jaxb2-plugin/wiki/Using-a-Specific-JAXB-Version

扫码关注云+社区

领取腾讯云代金券