首先升级symfony 2.8或php 5.4?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (121)

我很快就会在一个项目上工作,我之前想问这个问题。该项目在symfony 2.8上使用php 5.4。目标是将symfony升级到3.4(可能是4.x之后)和php升级到7.x(可能是7.2)。所以这是我的问题:有没有更好的命令来做到这一点?首先是5.4到7.2或者是2.8到3.4的symfony(或者没关系)?谢谢你的建议。

提问于
用户回答回答于

首先 - 您将无法在PHP5.4上运行Symfony 3.4项目。

截至2018-11-26

最新的Symfony ^ 3.4版本v3.4.19需要php: ^5.5.9|>=7.0.8

另一方面,最新的Symfony ^ 2.8版本v2.8.48需要php: >=5.3.9

结论

您将无法在PHP 5.4上运行Symfony 3.4项目,但理论上您将能够使用PHP 7.2运行Symfony 2.8项目。

您还应该考虑查看:http//php.net/manual/en/migration70.incompatible.php

用户回答回答于

只要Symfony允许你,我就会先使用PHP。遵循PHP代码中的更改然后更改大PHP框架要容易得多。

最好的方法是使用Rector(我编写的工具)进行即时升级:

vendor/bin/rector process src --level php53
vendor/bin/rector process src --level php54
vendor/bin/rector process src --level symfony30
vendor/bin/rector process src --level php55
vendor/bin/rector process src --level symfony31
vendor/bin/rector process src --level php56
vendor/bin/rector process src --level symfony32
vendor/bin/rector process src --level php70
vendor/bin/rector process src --level php71
vendor/bin/rector process src --level symfony33
vendor/bin/rector process src --level symfony34

总是一个版本在同一时间!

扫码关注云+社区

领取腾讯云代金券