如何查看浏览器需要哪个ES版本?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (202)

我有一个使用webpack捆绑的JS应用程序。它主要是VueJs,有一些jQuery和原始JS。它调用了许多库并使用了一些ES6功能。

我认为webpack正在向ES5发展,但我并不是100%肯定。我希望能够检查输出JS,以确定它是否绝对是ES5或更低。我怎样才能做到这一点?

我尝试了这个节点模块,https://www.npmjs.com/package/es-check,但是没有任何意义。它一直说它找不到任何要检查的文件。

提问于
用户回答回答于

一个简单的解决方案可能是grep在捆绑包上使用或类似,并搜索以下任何一个:

cat bundle.js | grep =\>
  • 箭头功能 =\>
  • 声明 let\ const\

扫码关注云+社区

领取腾讯云代金券