flutter:在> pubspec.yaml中使用cloud_firestore包时,“> = 0.2.4 <2.0.0”pub失败(65)

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (1)
  • 关注 (0)
  • 查看 (75)

当我尝试添加google_sign_in,flutter_auth和cloud_firestore时,它正在向我抛出一个颤动的错误:“> = 0.2.4 <2.0.0”。我试图运行flutter dector -v输出是

[✓] Flutter(渠道稳定,v1.5.4-hotfix.2,在Linux上,locale en_US.UTF-8)•Flutter版本1.5.4-hotfix.2在/ home / ramu / Downloads / tools / flutter•框架修订7a4c33425d(4周前),2019-04-29 11:05:24 -0700•引擎版本52c7a1e849•Dart版本2.3.0(版本2.3.0-dev.0.5 a1668566e5)

[✓] Android工具链 - 针对Android设备开发(Android SDK版本28.0.3)•Android SDK / home / ramu / Android / Sdk•Android NDK位置未配置(可选;对原生分析支持很有用)•平台android-28 ,build-tools 28.0.3•ANDROID_HOME = / home / ramu / Android / Sdk•Java二进制文件:/ snap / android-studio / 73 / android-studio / jre / bin / java•Java版OpenJDK运行时环境(版本1.8) .0_152-release-1248-b01)•接受所有Android许可。

[✓] Android Studio(版本3.3)•Android Studio at / snap / android-studio / 73 / android-studio•Flutter插件版本34.0.1•Dart插件版本182.5215•Java版OpenJDK运行时环境(版本1.8.0_152-发布-1248-B01)

[✓] VS Code(版本1.34.0)•VS代码/ usr / share / code•Flutter扩展版本3.0.2

[!]连接设备!没有可用的设备

!医生在1类中发现了问题。

firebase_auth:^ 0.6.2 + 1 google_sign_in:^ 3.2.2 cloud_firestore:^ 0.8.2 + 3

提问于
用户回答回答于

尝试在更新你的环境的SDK pubspec.yaml>=0.2.4 <2.0.0>=2.1.0 <3.0.0

的上限为您的环境SDK低于2.0.0版本,但google_sign_infirebase_authcloud_firestore至少需要>=2.0.0-dev.28.0(这是新的,那么你已经为你的项目中指定的)。

扫码关注云+社区

领取腾讯云代金券