将Rails从5.1升级到5.2后,我收到了以下警告消息

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (9)

将Rails从5.1升级到5.2后,我收到了以下警告消息。

[fog][DEPRECATION] Unable to load Fog::AWS::CDN
[fog][DEPRECATION] The format Fog::CDN::AWS is deprecated
[fog][DEPRECATION] Unable to load Fog::AWS::Compute
[fog][DEPRECATION] The format Fog::Compute::AWS is deprecated
[fog][DEPRECATION] Unable to load Fog::AWS::DNS
[fog][DEPRECATION] The format Fog::DNS::AWS is deprecated
[fog][DEPRECATION] Unable to load Fog::AWS::Storage
[fog][DEPRECATION] The format Fog::Storage::AWS is deprecated

的Gemfile

gem 'rails', '~> 5.2'
gem 'aws-sdk', '~> 2'
gem 'fog-aws'

我怎样才能解决这个问题?

提问于
用户回答回答于
用户回答回答于

我有同样的错误fog-openstack。 看起来雾的最新版本并不完全清洁(参见下面的来源)。 我通过降级fog-openstack到之前的版本(即gem "fog-openstack", '~>0.1.23')解决了这个问题。

来源https://github.com/fog/fog/issues/4014

扫码关注云+社区

领取腾讯云代金券