云通信是不是不提供64位的支持,只支持32位的设备?

  • 回答 (2)
  • 关注 (0)
  • 查看 (46)

我在我的AS的build.gradle中加入 ndk.abiFilters 'armeabi',"armeabi-v7a"可以正常编译通过,当我加入ndk.abiFilters 'armeabi',"armeabi-v7a", "arm64-v8a" 时,就会报错:system load so library error:dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/base.apk"],nativeLibraryDirectories=[/data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/lib/arm64, /data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/base.apk!/lib/arm64-v8a, /system/lib64, /vendor/lib64, /product/lib64]]] couldn't find "libqalcodecwrapper.so"

imsdk.IMCoreWrapper: [E]LoadLibrary|2-Loading|system load failedjava.lang.UnsatisfiedLinkError: dalvik.system.PathClassLoader[DexPathList[[zip file "/data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/base.apk"],nativeLibraryDirectories=[/data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/lib/arm64, /data/app/com.loveme.dating-QqyOgwpNhF9xOjBZt7XuwQ==/base.apk!/lib/arm64-v8a, /system/lib64, /vendor/lib64, /product/lib64]]] couldn't find "lib_imcore_jni_gyp.so"

我也试着把这两个so库加入到/arm64-v8a中,还是不行,不知道怎么解决?

用户1803170用户1803170提问于
用户1803170回答于

您好,能给出最新版本具体链接么?多谢!

Richel码农回答于

您好,确认下您使用的版本是否最新版本。

从您提供的信息来看,是旧版本。新版本里目前就两个so。

如果问题未得到解决,可以添加QQ3268519604对接相关人员协助帮您解决问题,感谢您对腾讯云通信IM的理解与支持。

所属标签

可能回答问题的人

  • HKC

    红客学院 · 创始人 (已认证)

    27 粉丝7 提问5 回答
  • 西风

    renzha.net · 站长 (已认证)

    9 粉丝1 提问3 回答
  • 螃蟹居

    1 粉丝0 提问2 回答
  • 富有想象力的人

    2 粉丝0 提问1 回答

扫码关注云+社区

领取腾讯云代金券