IDEA:javac:source release 1.7需要目标版本1.7?

  • 回答 (2)
  • 关注 (0)
  • 查看 (276)

当运行一个JUnit测试,使用IntelliJ IDEA

IDEA:javac:source release 1.7需要目标版本1.7

我怎样才能纠正这一点?

  • 使用SDK 1.7
  • 模块语言级别是1.7

Maven构建工作正常。

火星救援队长火星救援队长提问于
以往V回答于

我遇到了这个问题,修复方法是去项目设置>模块>点击特定的模块>依赖关系选项卡。我注意到模块SDK仍然设置在1.6,我把它改为1.7,它的工作。

人生的旅途辣鸡前端回答于

如果你使用maven 3和JDK 7,你看过你的构建配置吗?

<build>
    <finalName>SpringApp</finalName>
    <plugins>
        <plugin>
            <artifactId>maven-compiler-plugin</artifactId>
            <configuration>
                <source>1.7</source>
                <target>1.7</target>
            </configuration>
        </plugin>
        ...
    </plugins>
    ...
</build>

扫码关注云+社区

领取腾讯云代金券

年度创作总结 领取年终奖励