在Ubuntu的PHP GD库错误?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (54)

我使用的是ubuntu 11.04,当我打开终端并输入php -a它显示出这样的错误

PHP Warning:  PHP Startup: Unable to load dynamic library '/usr/lib/php5/20090626/gd.so' - /usr/lib/php5/20090626/gd.so: cannot open shared object file: No such file or directory in Unknown on line 0

我认为GD库存在一些问题。有什么办法解决这个问题吗?

提问于
用户回答回答于

可能是类似的东西

sudo apt-get install php-gd

应该这样做

apt-cache search php | grep gd
用户回答回答于

你试一试:

sudo apt-get install php5-gd

你可能将不得不删除php.ini中的有问题的行,或者在php.ini中或者在/etc/php5/conf.d/gd.ini中。

扫码关注云+社区

领取腾讯云代金券