如何更改Eclipse项目的JDK版本?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (25)

我需要编写一个仅与Java 1.5兼容的项目。我安装了Java 1.6。是否有某种形式的向后兼容性让Eclipse能够用1.5进行编译?

我必须安装Java 1.5才能在此显示吗?或者,也许有另一种方式?

.

提问于
用户回答回答于

点击添加库按钮。它将你的屏幕指向Java位置。

选择“ 目录 ”,除了JRE home之外的按钮,并指向安装的文件夹位置。

即使只想要1.5编译器项目,也可以通过在Eclipse中更改编译器设置来实现,而不是删除1.6 JRE并添加1.5 JRE。

GOTO -->JAVA--Compiler---> and change compiler level to `1.5` instead of `1.6`

用户回答回答于

点击Eclipse中的Window选项卡,进入Preferences,当该窗口出现时,进入JavaInstalled JREsExecution Environment并选择JavaSE-1.5。然后你必须去编译器并设置编译器符合性级别

扫码关注云+社区