Android工作室中无法找到目标android-18该怎么办?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (24)

我遇到了Android Studio 0.2.3的问题。

当我运行我的项目时,构建停止并显示消息:

Gradle:任务执行失败':AppName:compileDebugAidl'。 >未能找到目标android-18

尽管我已经安装了Android 4.3(API 18)的SDK平台,但我试图重新安装所有的SDK。我也在ANDROID_HOME系统变量中添加了这个变量。

提问于
用户回答回答于

我想你可能没有安装Android-18 sdk。转到工具> Android> SDK管理器,并检查是否安装了Android 4.3。

用户回答回答于

我通过改变解决了这个问题compileSdkVersionGradle.build文件从18到17:

buildscript {
    repositories {
        mavenCentral()
    }
    dependencies {
        classpath 'com.android.tools.build:gradle:0.5.+'
    }
}
apply plugin: 'android'

repositories {
    mavenCentral()
}

android {
    compileSdkVersion 17
    buildToolsVersion "17.0.0"

    defaultConfig {
        minSdkVersion 10
        targetSdkVersion 18
    }
}

dependencies {
    compile 'com.android.support:support-v4:13.0.+'
}

扫码关注云+社区