无法安装Android 4.2 API该怎么办?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (15)

我今天通过Eclipse更新了ADT到版本21.现在,当我打开SDK管理器时,我期望有一个像“Android 4.2(API 17)”的文件夹,其中将包含SDK平台和API,文档等。但是,相反,我只是得到一个名为“API 17”的文件夹,其中唯一的是“Google API”,我甚至无法安装它

安装此软件包还需要安装: - 缺少SDK平台Android,API 17

提问于
用户回答回答于

我在一番探索之后自己想出了这件事。我进入了SDK管理器的设置,清除了缓存,并告诉它使用HTTPS,然后刷新了列表,并且它全部正常显示。

用户回答回答于

Eclipse>窗口> Android SDK Manager > > 重新加载

然后,它正确地更新了用户界面,让我选择更新的软件。

为什么需要手动点击“重新加载”?

扫码关注云+社区