此版本的android studio与使用的gradle版本不兼容该怎么办?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (13)

我能够正确地构建应用程序,但是当我运行它时,出现此错误:

This version of android studio is incompatible with the gradle version used.Try disabling the instant run
提问于
用户回答回答于

你可以使用正常的生成运行而不是即时运行:

先检查 :

转至设置/首选项 > 构建,执行,部署选项 > 即时运行,取消选中所有三个框:

  1. 升级Gradle服务URL: Project> Gradle> Wrapper> gradle-wrapper.properties 从中更改网址 distributionUrl=https\://services.gradle.org/distributions/gradle-2.10-all.zip distributionUrl=https\://services.gradle.org/distributions/gradle-2.11-all.zip

(查找最新的distributionUrl gradle插件版本在这里:http ://services.gradle.org/distributions

**确保使用gradle-x.xx-all.zip)

  1. 删除您的生成文件夹 当你运行项目时,build文件夹将自动创建
  2. 转至菜单>清理项目,生成项目中的BUILD选项 它应该没有即时运行的工作。
用户回答回答于

我有简单的步骤和正确的方法:

1 - 在Settings- > Build, Execution, Deployment选项 - >Instant Run

2 - 清除 Enable instant run to hot swap code

3 - 清洁项目

扫码关注云+社区