Warning - Build path specifies execution environment J2SE-1.4,如何解决?

内容来源于 Stack Overflow,并遵循CC BY-SA 3.0许可协议进行翻译与使用

  • 回答 (2)
  • 关注 (0)
  • 查看 (24)

我在EclipseHelios中创建了一个Maven项目。这一天运行良好,但随后出现了以下警告:

Build path specifies execution environment J2SE-1.4. There are no JREs installed in the workspace that are strictly compatible with this environment.

由于此消息,项目停止编译和调试。有人能解决这个问题吗?

提问于
用户回答回答于

在Eclipse中,您的项目:

  1. 右击项目
  2. 点击特性
  3. Java构建路径:库;删除“JRE系统库”J2SE 1.4“
  4. 点击添加库->JRE系统库
  5. 选择新的“执行环境”或工作区默认的JRE
用户回答回答于

将以下内容添加到项目的pom.xml,保存,然后转到Eclipse项目并选择Properties>Maven>UpdateProjectConfiguration:

<project>
 <build>
  <pluginManagement>
   <plugins>
    <plugin>
        <groupId>org.apache.maven.plugins</groupId>
        <artifactId>maven-compiler-plugin</artifactId>          
        <configuration>
            <source>1.6</source>
            <target>1.6</target>
        </configuration>
    </plugin>
   </plugins>
  </pluginManagement>
 </build>
</project>

扫码关注云+社区